summaryrefslogtreecommitdiffstats
path: root/abs/extra/terminus-font/install.proto
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/terminus-font/install.proto
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/terminus-font/install.proto')
-rw-r--r--abs/extra/terminus-font/install.proto27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/terminus-font/install.proto b/abs/extra/terminus-font/install.proto
new file mode 100644
index 0000000..37f0b55
--- /dev/null
+++ b/abs/extra/terminus-font/install.proto
@@ -0,0 +1,27 @@
+# arg 1: the new package version
+ post_install() {
+ echo -n "Updating font cache... "
+ /usr/bin/fc-cache
+ cd /usr/share/fonts/local
+ /usr/bin/mkfontdir
+ /usr/bin/mkfontscale
+# cp ../encodings/encodings.dir ./encodings.dir
+ echo "done."
+ echo "Note that local fonts are now (with xorg-7.0) in /usr/share/fonts/local/"
+ }
+
+# # arg 1: the new package version
+# # arg 2: the old package version
+ post_upgrade() {
+ post_install $1
+ }
+#
+# # arg 1: the old package version
+ post_remove() {
+ /usr/bin/fc-cache
+ }
+
+op=$1
+shift
+
+$op $*