summaryrefslogtreecommitdiffstats
path: root/abs/extra/ttf-liberation
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2012-03-12 21:26:10 (GMT)
committerBritney Fransen <brfransen@gmail.com>2012-03-12 21:26:10 (GMT)
commit7219eb2f85b5c61f6708f277b5756db0c9fdb627 (patch)
tree65cd04f50dfe102bc7d74267f7e9f95aa7e46757 /abs/extra/ttf-liberation
parentfd936e5ece64c337e9ce43bad28db35771d9d124 (diff)
downloadlinhes_pkgbuild-7219eb2f85b5c61f6708f277b5756db0c9fdb627.zip
linhes_pkgbuild-7219eb2f85b5c61f6708f277b5756db0c9fdb627.tar.gz
linhes_pkgbuild-7219eb2f85b5c61f6708f277b5756db0c9fdb627.tar.bz2
ttf-liberation: Initial inclusion. Needed for mythcenter* themes
Diffstat (limited to 'abs/extra/ttf-liberation')
-rw-r--r--abs/extra/ttf-liberation/PKGBUILD31
-rw-r--r--abs/extra/ttf-liberation/ttf.install16
2 files changed, 47 insertions, 0 deletions
diff --git a/abs/extra/ttf-liberation/PKGBUILD b/abs/extra/ttf-liberation/PKGBUILD
new file mode 100644
index 0000000..572ae06
--- /dev/null
+++ b/abs/extra/ttf-liberation/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: Andreas Zwinkau
+# Contributor: rabyte <rabyte__gmail>
+# Contributor: Stefan Husmann < stefan-husmann@t-online.de>
+
+pkgname=ttf-liberation
+pkgver=1.07.1
+pkgrel=2
+pkgdesc='Red Hats Liberation fonts.'
+arch=('any')
+license=('custom' 'GPL2')
+url='https://www.redhat.com/promo/fonts/'
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('fontforge')
+install=ttf.install
+source=("https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-$pkgver.tar.gz")
+md5sums=('0be45d54cc5e1c2e3102e32b8c190346')
+
+package() {
+ cd "$srcdir/liberation-fonts-ttf-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+
+ # install license
+ install -Dm644 "${srcdir}/liberation-fonts-ttf-${pkgver}/License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+}
diff --git a/abs/extra/ttf-liberation/ttf.install b/abs/extra/ttf-liberation/ttf.install
new file mode 100644
index 0000000..7d26d0c
--- /dev/null
+++ b/abs/extra/ttf-liberation/ttf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+