summaryrefslogtreecommitdiffstats
path: root/abs/extra/wayland/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-28 18:57:06 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-28 18:57:06 (GMT)
commitf2e5941f08994c68060b419edb6b68d78dcd9614 (patch)
tree94b543a4021ebc7bd66fce8b882aa71ca1a3964e /abs/extra/wayland/PKGBUILD
parent32f4c73fb045b8d3efe09e43f82922290d0bceab (diff)
downloadlinhes_pkgbuild-f2e5941f08994c68060b419edb6b68d78dcd9614.zip
linhes_pkgbuild-f2e5941f08994c68060b419edb6b68d78dcd9614.tar.gz
linhes_pkgbuild-f2e5941f08994c68060b419edb6b68d78dcd9614.tar.bz2
wayland: update to 1.13.0
Diffstat (limited to 'abs/extra/wayland/PKGBUILD')
-rw-r--r--abs/extra/wayland/PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/abs/extra/wayland/PKGBUILD b/abs/extra/wayland/PKGBUILD
index 63bef97..2bb1829 100644
--- a/abs/extra/wayland/PKGBUILD
+++ b/abs/extra/wayland/PKGBUILD
@@ -4,21 +4,24 @@
# Contributor: Joel Teichroeb <joel@teichroeb.net>
pkgname=wayland
-pkgver=1.6.0
+pkgver=1.13.0
pkgrel=1
pkgdesc='A computer display server protocol'
arch=('i686' 'x86_64')
-url='http://wayland.freedesktop.org'
+url='https://wayland.freedesktop.org/'
license=('MIT')
-depends=('libffi' 'expat')
-makedepends=('doxygen')
-source=("http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz")
-sha1sums=('6183108a3bffb204c05b7f37b763b6278760572d')
+depends=('glibc' 'libffi' 'expat' 'libxml2')
+validpgpkeys=('C7223EBE4EF66513B892598911A30156E0E67611') # Bryce Harrington
+source=("https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"{,.sig})
+sha1sums=('a8575325ed2885948624043c71629310df928312'
+ 'SKIP')
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
+ --disable-documentation \
--disable-static
make
}
@@ -29,3 +32,5 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
+
+# vim:set ts=2 sw=2 et: