summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
committerCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
commitc034db2c880091379f7e58c2938a9689d78fbaa9 (patch)
tree8a074205a2f3bf6ee7fb5945c53e1a1618d41973 /abs/extra
parent73b42144585c603fc64e7b1d6a126ceb7c486870 (diff)
parentb0c5755ade92ee5b76a6d56248e64254876bc931 (diff)
downloadlinhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.zip
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.gz
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/ddclient/PKGBUILD12
-rw-r--r--abs/extra/ddclient/__changelog1
-rw-r--r--abs/extra/ddclient/ddclient-foreground.patch47
-rwxr-xr-xabs/extra/wol/PKGBUILD28
-rwxr-xr-xabs/extra/wol/wakeonlan.sh10
-rw-r--r--abs/extra/wol/wol.install20
6 files changed, 93 insertions, 25 deletions
diff --git a/abs/extra/ddclient/PKGBUILD b/abs/extra/ddclient/PKGBUILD
index 4942d7b..77be4a8 100644
--- a/abs/extra/ddclient/PKGBUILD
+++ b/abs/extra/ddclient/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ddclient
pkgver=3.8.0
-pkgrel=2
+pkgrel=4
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services."
arch=('any')
url="http://ddclient.sourceforge.net/"
@@ -12,13 +12,11 @@ license=('GPL2')
depends=('perl' 'perl-io-socket-ssl')
backup=('etc/ddclient/ddclient.conf' 'etc/conf.d/ddclient')
install=ddclient.install
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d)
-md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
- '7035bf8132f3517a59167f61ee5e8b90'
- 'b8f39c82827776da948b76ef83544d33')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d ddclient-foreground.patch)
build() {
cd ${srcdir}/ddclient-${pkgver}
+ patch < ${srcdir}/ddclient-foreground.patch
# core files
install -D -m755 ddclient ${pkgdir}/usr/sbin/ddclient
@@ -33,3 +31,7 @@ build() {
install -D -m644 sample-etc_dhcpc_dhcpcd-eth0.exe ${pkgdir}/etc/ddclient/samples/sample-etc_dhcpc_dhcpcd-eth0.exe
install -D -m644 sample-etc_ppp_ip-up.local ${pkgdir}/etc/ddclient/samples/sample-etc_ppp_ip-up.local
}
+md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
+ '7035bf8132f3517a59167f61ee5e8b90'
+ 'b8f39c82827776da948b76ef83544d33'
+ 'd8ffc95f98f9afcb4a06a1e192220e35')
diff --git a/abs/extra/ddclient/__changelog b/abs/extra/ddclient/__changelog
new file mode 100644
index 0000000..64ae3f0
--- /dev/null
+++ b/abs/extra/ddclient/__changelog
@@ -0,0 +1 @@
+add ddclient-foreground.patch. Without this ddclient will not work with runit
diff --git a/abs/extra/ddclient/ddclient-foreground.patch b/abs/extra/ddclient/ddclient-foreground.patch
new file mode 100644
index 0000000..a814ede
--- /dev/null
+++ b/abs/extra/ddclient/ddclient-foreground.patch
@@ -0,0 +1,47 @@
+--- ../ddclient-orig/ddclient 2009-10-19 22:45:15.000000000 +1030
++++ ddclient 2009-10-19 22:50:11.000000000 +1030
+@@ -307,6 +307,7 @@
+ my %variables = (
+ 'global-defaults' => {
+ 'daemon' => setv(T_DELAY, 0, 0, 1, 0, interval('60s')),
++ 'foreground' => setv(T_BOOL, 0, 0, 1, 0, undef),
+ 'file' => setv(T_FILE, 0, 0, 1, "$etc$program.conf", undef),
+ 'cache' => setv(T_FILE, 0, 0, 1, "$cachedir$program.cache", undef),
+ 'pid' => setv(T_FILE, 0, 0, 1, "", undef),
+@@ -535,6 +536,7 @@
+ "usage: ${program} [options]",
+ "options are:",
+ [ "daemon", "=s", "-daemon delay : run as a daemon, specify delay as an interval." ],
++ [ "foreground", "!", "-foreground : do not fork" ],
+ [ "proxy", "=s", "-proxy host : use 'host' as the HTTP proxy" ],
+ [ "server", "=s", "-server host : update DNS information on 'host'" ],
+ [ "protocol", "=s", "-protocol type : update protocol used" ],
+@@ -623,7 +625,10 @@
+ $SIG{'HUP'} = sub { $caught_hup = 1; };
+ $SIG{'TERM'} = sub { $caught_term = 1; };
+ $SIG{'KILL'} = sub { $caught_kill = 1; };
+-if (opt('daemon') && !opt('force')) {
++# don't fork() if foreground or force is on
++if (opt('foreground') || opt('force')) {
++ ;
++} elsif (opt('daemon')) {
+ $SIG{'CHLD'} = 'IGNORE';
+ my $pid = fork;
+ if ($pid < 0) {
+@@ -633,12 +638,15 @@
+ exit 0;
+ }
+ $SIG{'CHLD'} = 'DEFAULT';
+- $opt{'syslog'} = 1;
+ open(STDOUT, ">/dev/null");
+ open(STDERR, ">/dev/null");
+ open(STDIN, "</dev/null");
++}
+
++# write out the pid file if we're daemon'ized
++if(opt('daemon')) {
+ write_pid();
++ $opt{'syslog'} = 1;
+ }
+
+ umask 077;
diff --git a/abs/extra/wol/PKGBUILD b/abs/extra/wol/PKGBUILD
index a9bb4eb..87bfc70 100755
--- a/abs/extra/wol/PKGBUILD
+++ b/abs/extra/wol/PKGBUILD
@@ -1,19 +1,27 @@
+# $Id: PKGBUILD 17446 2010-05-24 10:42:15Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Anders Bergh <anders1@gmail.com>
# Contributor: Markus Volkmann <mcfock@counterstrike.de>
+
pkgname=wol
pkgver=0.7.1
-pkgrel=3
+pkgrel=4
+arch=('i686' 'x86_64')
pkgdesc="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
-license="GPL"
+license=("GPL")
+depends=(sh)
url="http://ahh.sourceforge.net/wol/"
-arch=('i686')
-source=(http://easynews.dl.sourceforge.net/sourceforge/ahh/wol-$pkgver.tar.gz wakeonlan.sh)
+install=wol.install
+source=(http://downloads.sourceforge.net/ahh/wol-$pkgver.tar.gz)
md5sums=('c2fa9d7e771134ac8c89d56b8197d4ca')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make prefix=$startdir/pkg/usr install
- install -m755 $startdir/src/wakeonlan.sh $startdir/pkg/usr/bin/wakeonlan.sh
-}
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install || return 1
+ mv $pkgdir/usr/man $pkgdir/usr/share/ && \
+ mv $pkgdir/usr/info $pkgdir/usr/share/ && \
+ rm $pkgdir/usr/share/info/dir
+}
diff --git a/abs/extra/wol/wakeonlan.sh b/abs/extra/wol/wakeonlan.sh
deleted file mode 100755
index f87dd34..0000000
--- a/abs/extra/wol/wakeonlan.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-DIR="/data/srv/hobbit/var/hostdata/$1"
-FILE=`ls -t --group-directories-first $DIR|tail -n 1`
-for mac in `grep HW "$DIR/$FILE" |awk '{ print $5 } '`
-do
- /usr/bin/wol -v $mac
-done
-
-
-
diff --git a/abs/extra/wol/wol.install b/abs/extra/wol/wol.install
new file mode 100644
index 0000000..500ea57
--- /dev/null
+++ b/abs/extra/wol/wol.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(wol.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}