summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-04-15 18:09:52 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-04-15 18:09:52 (GMT)
commitfc98dbe17ad2e565b67a6c5ec715ab2bcca161f0 (patch)
tree9b41479aa679f286ba72c516b8a1996b3851fa63 /abs/extra
parentc4b1cc7f705de9b4d539e8bba18170607e2c93f9 (diff)
parentab2b92bf6743790902c68e764b7e28b4aa0a681a (diff)
downloadlinhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.zip
linhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.tar.gz
linhes_pkgbuild-fc98dbe17ad2e565b67a6c5ec715ab2bcca161f0.tar.bz2
Merge branch 'testing' of git@linhes.org:linhes_pkgbuild into testing
Conflicts: abs/core/LinHES-system/PKGBUILD
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/bluez/PKGBUILD11
-rw-r--r--abs/extra/bluez/__changelog3
-rw-r--r--abs/extra/bluez/audio-streaming.patch (renamed from abs/extra/bluez/bluez-4.98_audio-streaming.patch)1
-rw-r--r--abs/extra/bluez/bluez.install4
-rw-r--r--abs/extra/crystalhd-git/PKGBUILD28
-rw-r--r--abs/extra/huludesktop/PKGBUILD4
-rw-r--r--abs/extra/huludesktop/huludesktop2
-rw-r--r--abs/extra/libcrystalhd-git/PKGBUILD2
-rw-r--r--abs/extra/rtmpdump/PKGBUILD39
-rw-r--r--abs/extra/xbmc/PKGBUILD17
-rw-r--r--abs/extra/xbmc/xbmc.install4
-rw-r--r--abs/extra/xbmc/xbmc.sh7
-rw-r--r--abs/extra/xbmc/xbmc11.patch15
13 files changed, 87 insertions, 50 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index c1f675a..e6837e9 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=bluez
pkgver=4.99
-pkgrel=2
+pkgrel=3
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
@@ -26,11 +26,15 @@ backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
install='bluez.install'
source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
- 'bluetooth.conf.d')
+ 'bluetooth.conf.d'
+ 'audio-streaming.patch')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+# Add setting that allows audio streaming out-of-the-box
+ patch -Np1 -i ${srcdir}/audio-streaming.patch || return 1
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -80,4 +84,5 @@ package() {
# rm "${pkgdir}"/usr/lib/udev/rules.d/97-bluetooth.rules
}
md5sums=('2387053eb5a7b02f37df4871df022a02'
- '7412982b440f29fa7f76a41a87fef985')
+ '7412982b440f29fa7f76a41a87fef985'
+ 'cc9c86af1ced7ad46fc7be114d32adfb')
diff --git a/abs/extra/bluez/__changelog b/abs/extra/bluez/__changelog
index 1c3b324..62a2048 100644
--- a/abs/extra/bluez/__changelog
+++ b/abs/extra/bluez/__changelog
@@ -14,3 +14,6 @@ http://article.gmane.org/gmane.comp.sysutils.supervision.general/1585/
- remove rc.bluetooth as we use runit
- disable-cups
- comment out removal of udev line
+
+2012-04-13
+re-add audio-streaming.patch for ootb audio streaming
diff --git a/abs/extra/bluez/bluez-4.98_audio-streaming.patch b/abs/extra/bluez/audio-streaming.patch
index 085d8ca..83705c5 100644
--- a/abs/extra/bluez/bluez-4.98_audio-streaming.patch
+++ b/abs/extra/bluez/audio-streaming.patch
@@ -11,4 +11,3 @@
+
# Switch to master role for incoming connections (defaults to true)
#Master=true
-
diff --git a/abs/extra/bluez/bluez.install b/abs/extra/bluez/bluez.install
index f9b757b..30bd262 100644
--- a/abs/extra/bluez/bluez.install
+++ b/abs/extra/bluez/bluez.install
@@ -2,12 +2,12 @@ post_install() {
add_service.sh bluetoothd
echo ">>> Only the bluetoothd daemon is started by default."
echo ">>> You can optionally add the following as required:"
- echo ">>> hidd dund pand rfcomm"
+ echo ">>> hidd dund pand sdpd rfcomm hid2hci"
echo ">>> $ sudo add_service.sh <service_name>"
}
pre_remove() {
- for d in { bluetoothd,hidd,dund,pand,rfcomm } ; do
+ for d in { bluetoothd,hidd,dund,pand,sdpd,rfcomm,hid2hci } ; do
if [ -d /var/service/${d} ] ; then
remove_servcie.sh $d
fi
diff --git a/abs/extra/crystalhd-git/PKGBUILD b/abs/extra/crystalhd-git/PKGBUILD
index 538c0ae..a7b3e7f 100644
--- a/abs/extra/crystalhd-git/PKGBUILD
+++ b/abs/extra/crystalhd-git/PKGBUILD
@@ -2,24 +2,24 @@
# Maintainer: Petteri Tolonen <petteri.tolonen[at]gmail.com>
pkgname=crystalhd-git
-pkgver=`date +%Y%m%d`
+pkgver=20111227
pkgrel=1
-pkgdesc="Broadcom Crystal HD kernel module from git.wilsonet.com"
+pkgdesc="Broadcom CrystalHD kernel module"
arch=('i686' 'x86_64')
-url="http://git.wilsonet.com/crystalhd.git/"
+url="http://linuxtv.org/git/jarod/crystalhd.git"
license=('GPL2')
-depends=()
-makedepends=('autoconf' 'kernel26-headers>=2.6.32.9' 'make' 'git')
-conflicts=('crystalhd')
+depends=('libcrystalhd-git')
+makedepends=('autoconf' 'make' 'git')
install='crystalhd-git.install'
-_gitroot='git://git.wilsonet.com/crystalhd.git'
+conflicts=('crystalhd')
+_gitroot='git://linuxtv.org/jarod/crystalhd.git'
_gitname='crystalhd'
build() {
cd $startdir/src
- msg "Connecting to git.wilsonet.com GIT server...."
+ msg "Connecting to the GIT server...."
if [ -d $startdir/src/$_gitname ] ; then
cd $_gitname && git pull origin
@@ -33,12 +33,20 @@ build() {
autoconf
./configure --prefix=/usr
- make KDIR=/lib/modules/2.6.34-LinHES/build || return 1
+ sed -i 's/'-Werror'/''/g' Makefile
+
+ if ! grep -q "<linux/delay.h>" $srcdir/crystalhd/driver/linux/crystalhd_flea_ddr.c
+ then
+ sed -i '26i #include <linux/delay.h>' $srcdir/crystalhd/driver/linux/crystalhd_flea_ddr.c
+ fi
+
+ make || return 1
+
mkdir -p $pkgdir/etc/udev/rules.d
mkdir -p $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
cp -f 20-crystalhd.rules $pkgdir/etc/udev/rules.d/
install -d $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
install -m 0644 crystalhd.ko $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
-
}
+md5sums=()
diff --git a/abs/extra/huludesktop/PKGBUILD b/abs/extra/huludesktop/PKGBUILD
index 58cd1ca..c9ced62 100644
--- a/abs/extra/huludesktop/PKGBUILD
+++ b/abs/extra/huludesktop/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=huludesktop
pkgver=0.2
-pkgrel=3
+pkgrel=4
pkgdesc="Hulu Desktop for Linux"
arch=(i686)
url="http://www.hulu.com/labs/hulu-desktop-linux"
@@ -21,5 +21,5 @@ build() {
install -D -m755 huludesktop.sh ${pkgdir}/usr/LH/bin
}
md5sums=('d9b27d1837ab86526100964e80c3cdd1'
- 'fc6048cc2a6ee3b90808e0b757f0fc9b'
+ '935d923b90abaa4b1838a5e6b23e704e'
'8f7dbf19d6168bc3a5b0c1da1c878693')
diff --git a/abs/extra/huludesktop/huludesktop b/abs/extra/huludesktop/huludesktop
index c3ae870..c3fc9a5 100644
--- a/abs/extra/huludesktop/huludesktop
+++ b/abs/extra/huludesktop/huludesktop
@@ -6,7 +6,7 @@ pos_x = 201
pos_y = 179
[remote]
-lirc_device = /dev/lircd
+lirc_device = /var/run/lirc/lircd
lirc_remote_identifier = mceusb
lirc_release_suffix = _UP
lirc_repeat_threshold = 10
diff --git a/abs/extra/libcrystalhd-git/PKGBUILD b/abs/extra/libcrystalhd-git/PKGBUILD
index 94c7be8..c0bf7d1 100644
--- a/abs/extra/libcrystalhd-git/PKGBUILD
+++ b/abs/extra/libcrystalhd-git/PKGBUILD
@@ -10,7 +10,7 @@ depends=('gcc-libs')
makedepends=('git' 'make')
conflicts=('libcrystalhd')
-_gitroot='git://git.wilsonet.com/crystalhd.git'
+_gitroot='git://linuxtv.org/jarod/crystalhd.git'
_gitname='crystalhd'
build() {
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index ee3c007..03263a4 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,34 +1,27 @@
-# Maintainer: xduugu
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
+
pkgname=rtmpdump
-pkgver=2.3
-pkgrel=2
-pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool to download rtmp streams"
arch=('i686' 'x86_64')
url="http://rtmpdump.mplayerhq.hu/"
-license=('LGPL')
+license=('GPL2' 'LGPL2.1')
depends=('openssl')
-source=(
- http://mirrors.kernel.org/gentoo/distfiles/$pkgname-$pkgver.tgz
- # Upstream is not accessible from Vodafone/Germany
- #http://rtmpdump.mplayerhq.hu/download/$pkgname-$pkgver.tgz
-)
-md5sums=('eb961f31cd55f0acf5aad1a7b900ef59')
-sha256sums=('ef38b7a99d82ce6912063d21063aeaf28185341b3df486e24bffce5354224b2c')
-
-#if [[ ! -e "$SRCDEST/${source[0]##*/}" ]]; then
- #cd "$SRCDEST"
- #download_file "$(get_downloadclient "$(get_url "${source[0]}")")" "$(get_url "${source[0]}")" "$(get_filename "${source[0]}")" \
- #|| download_file "$(get_downloadclient "$(get_url "${source[1]}")")" "$(get_url "${source[1]}")" "$(get_filename "${source[1]}")"
- #cd "$OLDPWD"
-#fi
+#source=(http://rtmpdump.mplayerhq.hu/download/${pkgname}-${pkgver}.tgz)
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('2c3b76d46d56180176ef099b8ad50a1608bef1dac35d8cb0b21ceac31b5c0656')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -i 's/^install_so.0:.*/& install_base/' librtmp/Makefile
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d -m755 "${pkgdir}/usr/lib"
+ make prefix=/usr mandir=/usr/share/man DESTDIR="${pkgdir}" install
}
diff --git a/abs/extra/xbmc/PKGBUILD b/abs/extra/xbmc/PKGBUILD
index 8206a42..49166cc 100644
--- a/abs/extra/xbmc/PKGBUILD
+++ b/abs/extra/xbmc/PKGBUILD
@@ -9,12 +9,12 @@ _prefix=/usr
pkgname=xbmc
pkgver=11.0
-pkgrel=2
+pkgrel=4
pkgdesc="A software media player and entertainment hub for digital media"
arch=('i686' 'x86_64')
url="http://xbmc.org"
license=('GPL' 'custom')
-depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva' 'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg' 'libsamplerate' 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez')
+depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva' 'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg' 'libsamplerate' 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez' 'linhes-scripts>=7-31')
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'libxinerama' 'zip' 'vdpau-video' 'libcec' 'udisks' 'upower' 'bluez')
optdepends=(
'libcec: support for Pulse-Eight USB-CEC adapter'
@@ -26,11 +26,11 @@ optdepends=(
'unrar: access compressed files without unpacking them'
)
install="${pkgname}.install"
-source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz")
-sha256sums=('1fe5d310c16138f26e2b13bc545604e95f48ace6c8636f23e77da402cd7b0b19')
+source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz" 'xbmc11.patch' 'xbmc.sh')
build() {
cd "${srcdir}/xbmc-$pkgver"
+ patch -p1 < ../xbmc11.patch
# fix lsb_release dependency
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
@@ -71,7 +71,8 @@ build() {
--enable-libusb \
--enable-libcec \
--enable-external-libraries \
- --disable-external-ffmpeg
+ --disable-external-ffmpeg \
+ --disable-crystalhd
# Now (finally) build
make
}
@@ -97,5 +98,11 @@ package() {
for licensef in LICENSE.GPL copying.txt; do
mv "${pkgdir}${_prefix}/share/doc/xbmc/${licensef}" "${pkgdir}${_prefix}/share/licenses/${pkgname}"
done
+
+ mkdir -p ${pkgdir}/usr/LH/bin
+ install -D -m 0755 ${srcdir}/xbmc.sh ${pkgdir}/usr/LH/bin
}
# vim:set ts=2 sw=2 et:
+md5sums=('9e8a26ee25173c7268abea7f1d82d428'
+ '5aa2e21a1f9fea60a2e5bb345e5aefd0'
+ 'f30d9a68daedd28482813ee40134f243')
diff --git a/abs/extra/xbmc/xbmc.install b/abs/extra/xbmc/xbmc.install
index 7823fb7..2964449 100644
--- a/abs/extra/xbmc/xbmc.install
+++ b/abs/extra/xbmc/xbmc.install
@@ -5,7 +5,7 @@ post_install() {
echo " <button>" >> /tmp/library.xml.tmp
echo " <type>MENU_XBMC</type>" >> /tmp/library.xml.tmp
echo " <text>Launch XBMC</text>" >> /tmp/library.xml.tmp
- echo " <action>EXEC /usr/bin/xbmc --lircdev /var/run/lirc/lircd</action>" >> /tmp/library.xml.tmp
+ echo " <action>EXEC /usrLH//bin/xbmc.sh</action>" >> /tmp/library.xml.tmp
echo " </button>" >> /tmp/library.xml.tmp
echo "<!--#XBMC-->" >> /tmp/library.xml.tmp
echo "" >> /tmp/library.xml.tmp
@@ -38,7 +38,7 @@ post_upgrade() {
echo " <button>" >> /tmp/library.xml.tmp
echo " <type>MENU_XBMC</type>" >> /tmp/library.xml.tmp
echo " <text>Launch XBMC</text>" >> /tmp/library.xml.tmp
- echo " <action>EXEC /usr/bin/xbmc --lircdev /var/run/lirc/lircd</action>" >> /tmp/library.xml.tmp
+ echo " <action>EXEC /usr/LH/bin/xbmc.sh</action>" >> /tmp/library.xml.tmp
echo " </button>" >> /tmp/library.xml.tmp
echo "<!--#XBMC-->" >> /tmp/library.xml.tmp
echo "" >> /tmp/library.xml.tmp
diff --git a/abs/extra/xbmc/xbmc.sh b/abs/extra/xbmc/xbmc.sh
new file mode 100644
index 0000000..a27f0f1
--- /dev/null
+++ b/abs/extra/xbmc/xbmc.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+#Stop XScreensaver
+stop_xss.sh &
+#Launch XBMC
+/usr/bin/xbmc --lircdev /var/run/lirc/lircd
+#Once XBMC exits, kill stop xss
+killall stop_xss.sh
diff --git a/abs/extra/xbmc/xbmc11.patch b/abs/extra/xbmc/xbmc11.patch
new file mode 100644
index 0000000..fb144d1
--- /dev/null
+++ b/abs/extra/xbmc/xbmc11.patch
@@ -0,0 +1,15 @@
+diff -ruaN xbmc-11.0.orig//xbmc/cores/dvdplayer/DVDInputStreams/DVDInputStreamRTMP.cpp xbmc-11.0/xbmc/cores/dvdplayer/DVDInputStreams/DVDInputStreamRTMP.cpp
+--- xbmc-11.0.orig//xbmc/cores/dvdplayer/DVDInputStreams/DVDInputStreamRTMP.cpp 2012-03-21 22:07:50.000000000 +0000
++++ xbmc-11.0/xbmc/cores/dvdplayer/DVDInputStreams/DVDInputStreamRTMP.cpp 2012-04-08 21:04:19.000000000 +0000
+@@ -22,9 +22,9 @@
+ #if (defined HAVE_CONFIG_H) && (!defined WIN32)
+ #include "config.h"
+ #endif
+-#ifdef _WIN32
++//#ifdef _WIN32
+ #include "system.h" // just for HAS_LIBRTMP
+-#endif
++//#endif
+
+ #ifdef HAS_LIBRTMP
+ #include "settings/AdvancedSettings.h"