summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-02-29 22:07:14 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-02-29 22:07:14 (GMT)
commitc69233b362d5957604fc63edd56d717641c8518d (patch)
treef933c7cb66ed09472a4a5d140a9d9ce01bba7095 /abs/extra
parent8ef53de1bfe8c699af552c0f507952f331a733a5 (diff)
downloadlinhes_pkgbuild-c69233b362d5957604fc63edd56d717641c8518d.zip
linhes_pkgbuild-c69233b362d5957604fc63edd56d717641c8518d.tar.gz
linhes_pkgbuild-c69233b362d5957604fc63edd56d717641c8518d.tar.bz2
libglvnd: initial inclusion. dep of nvidia-utils
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/libglvnd/LICENSE26
-rw-r--r--abs/extra/libglvnd/PKGBUILD38
2 files changed, 64 insertions, 0 deletions
diff --git a/abs/extra/libglvnd/LICENSE b/abs/extra/libglvnd/LICENSE
new file mode 100644
index 0000000..57bc4f4
--- /dev/null
+++ b/abs/extra/libglvnd/LICENSE
@@ -0,0 +1,26 @@
+Copyright (c) 2013, NVIDIA CORPORATION.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and/or associated documentation files (the
+"Materials"), to deal in the Materials without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Materials, and to
+permit persons to whom the Materials are furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+unaltered in all copies or substantial portions of the Materials.
+Any additions, deletions, or changes to the original source files
+must be clearly indicated in accompanying documentation.
+
+If only executable code is distributed, then the accompanying
+documentation must state that "this software is based in part on the
+work of the Khronos Group."
+
+THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS. \ No newline at end of file
diff --git a/abs/extra/libglvnd/PKGBUILD b/abs/extra/libglvnd/PKGBUILD
new file mode 100644
index 0000000..b3ef540
--- /dev/null
+++ b/abs/extra/libglvnd/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 249779 2015-10-27 00:47:25Z eric $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=libglvnd
+pkgver=0.0.0.20160210
+_commit=236710018777d8b16f62b5c275e3ee95af7052cd
+pkgrel=2
+pkgdesc="The GL Vendor-Neutral Dispatch library"
+arch=('i686' 'x86_64')
+url="https://github.com/NVIDIA/libglvnd"
+license=('custom:BSD-like')
+depends=('libxext')
+makedepends=('xorg-server-devel' 'git' 'python2')
+source=("git+https://github.com/NVIDIA/libglvnd.git#commit=$_commit"
+ LICENSE)
+sha1sums=('SKIP'
+ 'c88e07f333fcf8dcdbef370b85372b4d88ad8a66')
+
+build() {
+ cd $pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="${pkgdir}" install
+
+ # For compatibility with older nvidia drivers for bumblebee
+ # Symlinks to /usr/lib will be in nvidia-libgl
+ mkdir "$pkgdir/usr/lib/nvidia"
+ for _lib in libGL.so libGLESv1_CM.so libGLESv2.so; do
+ mv "$pkgdir"/usr/lib/$_lib* "$pkgdir"/usr/lib/nvidia/
+ done
+
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}