summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-10-25 22:33:24 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-10-25 22:33:24 (GMT)
commit59341635b2add859ab56c053311c8f135fbf0f07 (patch)
tree3cc0c67abedd59a20ee507611eefd5f4b471aa99 /abs/extra
parent39ddfccf213c01f0b7ee9b99956a069a62189d0a (diff)
downloadlinhes_pkgbuild-59341635b2add859ab56c053311c8f135fbf0f07.zip
linhes_pkgbuild-59341635b2add859ab56c053311c8f135fbf0f07.tar.gz
linhes_pkgbuild-59341635b2add859ab56c053311c8f135fbf0f07.tar.bz2
openmpi: 4.0.5
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/openmpi/PKGBUILD98
-rw-r--r--abs/extra/openmpi/system_ltdl.patch66
2 files changed, 45 insertions, 119 deletions
diff --git a/abs/extra/openmpi/PKGBUILD b/abs/extra/openmpi/PKGBUILD
index d6aa6e1..d94e7d2 100644
--- a/abs/extra/openmpi/PKGBUILD
+++ b/abs/extra/openmpi/PKGBUILD
@@ -1,67 +1,59 @@
-# $Id$
-# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
pkgname=openmpi
-pkgver=1.10.2
-pkgrel=1
+pkgver=4.0.5
+pkgrel=2
pkgdesc='High performance message passing library (MPI)'
-arch=(i686 x86_64)
-url='http://www.open-mpi.org'
-license=(custom)
-depends=(libltdl hwloc)
-makedepends=(inetutils valgrind gcc-fortran)
+url='https://www.open-mpi.org'
+arch=('x86_64')
+license=('custom:OpenMPI')
+depends=('glibc' 'libltdl' 'hwloc' 'openssh' 'zlib' 'libnl' 'perl')
+makedepends=('inetutils' 'valgrind' 'gcc-fortran')
optdepends=('gcc-fortran: fortran support')
-options=(staticlibs)
-source=(http://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
-sha1sums=('03934fc0a2dd0d0d2d0459d714a976eabca938fb')
+options=('staticlibs')
+source=(https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c58f3863b61d944231077f344fe6b4b8fbb83f3d1bc93ab74640bf3e5acac009')
+b2sums=('9709dc8c251d4f2be14d0ab498c5d0d0e59f95db98fb16d9e84fe3d30af5a8e2f9636bbceaf7ae4086a3312bcd6299f0e9e1ca609d658930a1f5abe1018311e1')
build() {
- cd $pkgname-$pkgver
-
- ./autogen.pl
- ./configure --prefix=/usr \
- --sysconfdir=/etc/${pkgname} \
- --enable-mpi-fortran=all \
- --libdir=/usr/lib/${pkgname} \
- --with-threads=posix \
- --enable-smp-locks \
- --with-valgrind \
- --enable-memchecker \
- --enable-pretty-print-stacktrace \
- --without-slurm \
- --with-hwloc=/usr \
- --with-libltdl=/usr \
- FC=/usr/bin/gfortran \
- LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
-
- make
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/${pkgname} \
+ --enable-mpi-fortran=all \
+ --libdir=/usr/lib/${pkgname} \
+ --enable-builtin-atomics \
+ --enable-mpi-cxx \
+ --with-valgrind \
+ --enable-memchecker \
+ --enable-pretty-print-stacktrace \
+ --without-slurm \
+ --with-hwloc=/usr \
+ --with-libltdl=/usr \
+ FC=/usr/bin/gfortran \
+ LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
+ make
}
check() {
- cd $pkgname-$pkgver
-
- make check
+ cd ${pkgname}-${pkgver}
+ make check
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- # FS#28583
- install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
- for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
- done
-
- # Openmpi's otfinfo conflicts with the one from texlive
- mv "$pkgdir"/usr/bin/otfinfo{,mpi}
-
- # Remove dangling symlink and useless file
- rm "$pkgdir"/usr/share/vampirtrace/config.log
-
- install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
- echo "/usr/lib/$pkgname" > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # FS#28583
+ install -dm 755 "${pkgdir}/usr/lib/pkgconfig"
+ for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
+ ln -sf "/usr/lib/openmpi/pkgconfig/${i}" "${pkgdir}/usr/lib/pkgconfig/"
+ done
+
+ install -dm 755 "${pkgdir}/etc/ld.so.conf.d"
+ echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/openmpi/system_ltdl.patch b/abs/extra/openmpi/system_ltdl.patch
deleted file mode 100644
index 300da38..0000000
--- a/abs/extra/openmpi/system_ltdl.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/config/ltdl.m4 b/config/ltdl.m4
-index ea76f4d..2f1cbfe 100644
---- a/config/ltdl.m4
-+++ b/config/ltdl.m4
-@@ -162,6 +162,8 @@ m4_defun([_LTDL_INSTALLABLE],
- fi
- fi
-
-+enable_ltdl_install=no
-+
- # If configure.ac declared an installable ltdl, and the user didn't override
- # with --disable-ltdl-install, we will install the shipped libltdl.
- case $enable_ltdl_install in
-diff --git a/ompi/debuggers/Makefile.am b/ompi/debuggers/Makefile.am
-index 2adf3fd..5b22a91 100644
---- a/ompi/debuggers/Makefile.am
-+++ b/ompi/debuggers/Makefile.am
-@@ -46,8 +46,7 @@ headers = \
- # Simple checks to ensure that the DSOs are functional
-
- dlopen_test_SOURCES = dlopen_test.c
--dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
--dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
-+dlopen_test_LDADD = -lltdl
-
- predefined_gap_test_SOURCES = predefined_gap_test.c
- predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
-diff --git a/ompi/debuggers/dlopen_test.c b/ompi/debuggers/dlopen_test.c
-index 029a4ee..023afb8 100644
---- a/ompi/debuggers/dlopen_test.c
-+++ b/ompi/debuggers/dlopen_test.c
-@@ -13,7 +13,7 @@
- #include <string.h>
- #include <stdlib.h>
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- static int do_test(void);
-
-diff --git a/test/support/components.c b/test/support/components.c
-index 41c4345..6b4b464 100644
---- a/test/support/components.c
-+++ b/test/support/components.c
-@@ -24,7 +24,7 @@
-
- #include "opal/constants.h"
- #include "opal/mca/mca.h"
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
-
- #include "components.h"
-
-diff --git a/test/support/components.h b/test/support/components.h
-index 6db1f0d..fc8dfc5 100644
---- a/test/support/components.h
-+++ b/test/support/components.h
-@@ -20,7 +20,7 @@
- #ifndef OMPI_SUPPORT_COMPONENTS_H
- #define OMPI_SUPPORT_COMPONENTS_H
-
--#include "opal/libltdl/ltdl.h"
-+#include "ltdl.h"
- #include "opal/mca/mca.h"
-
- BEGIN_C_DECLS