summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-05-30 23:06:41 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-05-30 23:06:41 (GMT)
commitc3fbba38954048149daf34fa27dc5564f8898042 (patch)
tree2d6eff25465b8de202216707dd84cc92dec5782c /abs/extra
parent31c9c160045a4136891b5e96c18f49abbcc063a0 (diff)
downloadlinhes_pkgbuild-c3fbba38954048149daf34fa27dc5564f8898042.zip
linhes_pkgbuild-c3fbba38954048149daf34fa27dc5564f8898042.tar.gz
linhes_pkgbuild-c3fbba38954048149daf34fa27dc5564f8898042.tar.bz2
rslsync: add rslsync.conf
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/rslsync/PKGBUILD10
-rw-r--r--abs/extra/rslsync/__changelog1
-rw-r--r--abs/extra/rslsync/rslsync.conf85
3 files changed, 93 insertions, 3 deletions
diff --git a/abs/extra/rslsync/PKGBUILD b/abs/extra/rslsync/PKGBUILD
index 4412d31..fc5b8ca 100644
--- a/abs/extra/rslsync/PKGBUILD
+++ b/abs/extra/rslsync/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=rslsync
pkgver=2.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Resilio Sync (ex:BitTorrent Sync) - automatically sync files via secure, distributed technology"
license=("custom:resilio")
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -17,7 +17,8 @@ conflicts=()
source=('rslsync.service'
'rslsync_user.service'
'rslsync.tmpfiles'
- 'rslsync.sysusers')
+ 'rslsync.sysusers'
+ 'rslsync.conf')
source_arm=("rslsync_arm-${pkgver}-${pkgrel}.tar.gz::https://download-cdn.resilio.com/stable/linux-arm/resilio-sync_arm.tar.gz")
source_armv6h=("rslsync_arm-${pkgver}-${pkgrel}.tar.gz::https://download-cdn.resilio.com/stable/linux-arm/resilio-sync_arm.tar.gz")
source_armv7h=("rslsync_armhf-${pkgver}-${pkgrel}.tar.gz::https://download-cdn.resilio.com/stable/linux-armhf/resilio-sync_armhf.tar.gz")
@@ -27,7 +28,8 @@ source_x86_64=("rslsync_x64-${pkgver}-${pkgrel}.tar.gz::https://download-cdn.res
sha256sums=('4483cbe3fff81281666d8fbe8c9b8d7d27c38ba7a3d3752a865f1ab8c1f212db'
'ba4b0ee3303027122e67345d4bf852f911a56f213f98c9eaa198c69d903fd8a1'
'58ba5cef05bcfde72c5841eaeffaa4d31c39e26902b5fefb2e17eb9b629416cf'
- '3c69179987c2e0f54b2f3478ab421c65515f5b5b9bad2b6e055ec04aea0f5c6d')
+ '3c69179987c2e0f54b2f3478ab421c65515f5b5b9bad2b6e055ec04aea0f5c6d'
+ '76e3b095ae35d5d7800928167e9a9b1662e257209c91f20e642eb009528d531c')
sha256sums_i686=('8fce5f59ad0b083a413e5a16cc6e0200c966d12a39e0721964923ce1221d7e7b')
sha256sums_x86_64=('ce1415403e089350bf6966af08d5822defd3e6d4a1cb902abc28d6f7fc247c9f')
sha256sums_arm=('bf1242a271c9ad23b0a34f247860981c8de8686ebd1300c1073513a4bfdf5188')
@@ -57,4 +59,6 @@ package() {
# install license
install -D -m 644 "${srcdir}"/LICENSE.TXT "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+
+ install -D -m 644 "${srcdir}"/rslsync.conf "${pkgdir}"/etc/rslsync.conf
}
diff --git a/abs/extra/rslsync/__changelog b/abs/extra/rslsync/__changelog
new file mode 100644
index 0000000..8d32241
--- /dev/null
+++ b/abs/extra/rslsync/__changelog
@@ -0,0 +1 @@
+PKGBUILD: add modified /etc/rslsync.conf
diff --git a/abs/extra/rslsync/rslsync.conf b/abs/extra/rslsync/rslsync.conf
new file mode 100644
index 0000000..7968aa4
--- /dev/null
+++ b/abs/extra/rslsync/rslsync.conf
@@ -0,0 +1,85 @@
+{
+ "device_name": "My Sync Device",
+// "listening_port" : 0, // 0 - randomize port
+
+/* storage_path dir contains auxilliary app files if no storage_path field: .sync dir created in current working directory */
+ "storage_path" : "/data/storage/disk0/media/resilio/.sync",
+
+/* set location of pid file */
+// "pid_file" : "/run/resilio/resilio.pid",
+
+/* use UPnP for port mapping */
+ "use_upnp" : true,
+
+/* limits in kB/s. 0 - no limit */
+ "download_limit" : 0,
+ "upload_limit" : 0,
+
+/* proxy configuration */
+// "proxy_type" : "socks4", // Valid types: "socks4", "socks5", "http_connect". Any other value means no proxy
+// "proxy_addr" : "192.168.1.2", // IP address of proxy server.
+// "proxy_port" : 1080,
+// "proxy_auth" : false, // Use authentication for proxy. Note: only username/password for socks5 (RFC 1929) is supported, and it is not really secure
+// "proxy_username" : "user",
+// "proxy_password" : "password",
+
+/* directory_root path defines where the WebUI Folder browser starts (linux only). Default value is / */
+ "directory_root" : "/data/storage/",
+
+/* directory_root_policy defines how directory_root is used (linux only).
+ Valid values are:
+ "all" - accepts directory_root and its subdirectories for 'getdir' and 'adddir' actions
+ "belowroot" - accepts directory_root's subdirectories for 'getdir' and 'adddir' actions,
+ but denies attempts to use 'adddir' to create directories directly within directory_root
+ Default value is "all". */
+// "directory_root_policy" : "all",
+
+ "webui" :
+ {
+ "listen" : "0.0.0.0:8888" // remove field to disable WebUI
+
+/* preset credentials. Use password or password_hash */
+// ,"login" : "admin"
+// ,"password" : "password" // (not recommended, better use 'password_hash_unified')
+// ,"password_hash" : "<crypt() 3 format password hash>" // (not recommended) Works on *nix only!
+// Use either 'password_hash' or 'password_hash_unified' (recommended), but not both of them!
+// ,"password_hash_unified" : "<SHA2-256 hash in HEX format>" // Works on all platforms.
+// ,"password_hash_salt_unified" : "<any text>" // Salt for unified password's hash. Works on all platforms.
+// ,"allow_empty_password" : false // Defaults to true
+/* ssl configuration */
+// ,"force_https" : true // disable http
+// ,"ssl_certificate" : "/path/to/cert.pem"
+// ,"ssl_private_key" : "/path/to/private.key"
+
+/* dir_whitelist defines which directories can be shown to user or have folders added (linux only)
+ relative paths are relative to directory_root setting */
+// ,"dir_whitelist" : [ "/home/user/MySharedFolders/personal", "work" ]
+ }
+
+/* !!! if you set shared folders in config file WebUI will be DISABLED !!!
+ shared directories specified in config file override the folders previously added from WebUI. */
+/*,
+ "shared_folders" :
+ [
+ {
+ "secret" : "MY_SECRET_1", // required field - use --generate-secret in command line to create new secret
+ "dir" : "/home/user/resilio/sync_test", // * required field
+ "use_relay_server" : true, // use relay server when direct connection fails
+ "use_tracker" : true,
+ "search_lan" : true,
+ "use_sync_trash" : true, // enable SyncArchive to store files deleted on remote devices
+ "overwrite_changes" : false, // restore modified files to original version, ONLY for Read-Only folders
+ "selective_sync" : false, // add folder in selective sync mode
+ "known_hosts" : // specify hosts to attempt connection without additional search
+ [
+ "192.168.1.2:44444"
+ ]
+ }
+ ]
+*/
+
+/* Advanced preferences can be added to config file. Info is available at "https://help.getsync.com/hc/en-us/articles/207371636"
+For example see folder_rescan_interval below */
+//, "folder_rescan_interval" : 600
+
+}