summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2020-06-15 01:14:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2020-06-15 01:14:33 (GMT)
commite11c3166911904ccbf6db4962458e683d0df8925 (patch)
treec4dc603a93931b078efa4076e91a7700f7faeefb /abs/extra
parent520042125a2aef4486fe1509db11016173013c71 (diff)
downloadlinhes_pkgbuild-e11c3166911904ccbf6db4962458e683d0df8925.zip
linhes_pkgbuild-e11c3166911904ccbf6db4962458e683d0df8925.tar.gz
linhes_pkgbuild-e11c3166911904ccbf6db4962458e683d0df8925.tar.bz2
transmission: update to 3.00
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/transmission/PKGBUILD24
-rw-r--r--abs/extra/transmission/__changelog1
-rw-r--r--abs/extra/transmission/transmission-2.90-libsystemd.patch13
3 files changed, 11 insertions, 27 deletions
diff --git a/abs/extra/transmission/PKGBUILD b/abs/extra/transmission/PKGBUILD
index 21b70bd..5cf059c 100644
--- a/abs/extra/transmission/PKGBUILD
+++ b/abs/extra/transmission/PKGBUILD
@@ -1,27 +1,23 @@
-# $Id$
# Maintainer : Tom Gundersen <teg@jklm.no>
# Maintainer : Ionut Biru <ibiru@archlinux.org>
pkgbase=transmission
-pkgname=(transmission-cli transmission-gtk transmission-qt)
-pkgver=2.93
+pkgname=(transmission-cli)
+pkgver=3.00
pkgrel=1
arch=(x86_64)
url="http://www.transmissionbt.com/"
license=(MIT)
-makedepends=(gtk3 intltool curl qt5-base libevent systemd qt5-tools)
+makedepends=(intltool curl libevent systemd)
source=(https://github.com/transmission/transmission-releases/raw/master/transmission-${pkgver}.tar.xz
- transmission-2.90-libsystemd.patch
transmission-cli.sysusers
transmission-cli.tmpfiles)
-sha256sums=('8815920e0a4499bcdadbbe89a4115092dab42ce5199f71ff9a926cfd12b9b90b'
- '9f8f4bb532e0e46776dbd90e75557364f495ec95896ee35900ea222d69bda411'
+sha256sums=('9144652fe742f7f7dd6657716e378da60b751aaeda8bef8344b3eefc4db255f2'
'641310fb0590d40e00bea1b5b9c843953ab78edf019109f276be9c6a7bdaf5b2'
'1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451')
prepare() {
cd $pkgbase-$pkgver
- patch -p1 -i "$srcdir/transmission-2.90-libsystemd.patch"
rm -f m4/glib-gettext.m4
autoreconf -fi
@@ -34,11 +30,11 @@ build() {
./configure --prefix=/usr
make
- cd qt
- qmake qtr.pro \
- DEFINES+=TRANSLATIONS_DIR=\\\\\\\"/usr/share/transmission-qt/translations\\\\\\\"
- make
- lrelease translations/*.ts
+ #cd qt
+ #qmake qtr.pro \
+ # DEFINES+=TRANSLATIONS_DIR=\\\\\\\"/usr/share/transmission-qt/translations\\\\\\\"
+ #make
+ #lrelease translations/*.ts
}
package_transmission-cli() {
@@ -64,7 +60,7 @@ package_transmission-cli() {
package_transmission-gtk() {
pkgdesc='Fast, easy, and free BitTorrent client (GTK+ GUI)'
depends=(curl libevent gtk3 desktop-file-utils hicolor-icon-theme)
- optdepends=('notification-daemon: Desktop notification support'
+ optdepends=('libnotify: Desktop notification support'
'transmission-cli: daemon and web support')
cd $pkgbase-$pkgver
diff --git a/abs/extra/transmission/__changelog b/abs/extra/transmission/__changelog
new file mode 100644
index 0000000..8f1054e
--- /dev/null
+++ b/abs/extra/transmission/__changelog
@@ -0,0 +1 @@
+PKGBUILD: don't build transmission-gtk and transmission-qt
diff --git a/abs/extra/transmission/transmission-2.90-libsystemd.patch b/abs/extra/transmission/transmission-2.90-libsystemd.patch
deleted file mode 100644
index 279a2c1..0000000
--- a/abs/extra/transmission/transmission-2.90-libsystemd.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index ea5e296..afd236f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -245,7 +245,7 @@ AC_ARG_WITH([systemd-daemon], AS_HELP_STRING([--with-systemd-daemon],
- [Add support for systemd startup notification (default is autodetected)]),
- [USE_SYSTEMD_DAEMON=$withval], [USE_SYSTEMD_DAEMON=auto])
- AS_IF([test "x$USE_SYSTEMD_DAEMON" != "xno"], [
-- PKG_CHECK_MODULES([SYSTEMD_DAEMON], [libsystemd-daemon],
-+ PKG_CHECK_MODULES([SYSTEMD_DAEMON], [libsystemd],
- [AC_DEFINE(USE_SYSTEMD_DAEMON,1,[Use systemd startup notification])],
- [AS_IF([test "x$USE_SYSTEMD_DAEMON" = "xyes"],
- [AC_MSG_ERROR([systemd startup notification support requested, but libsystemd-daemon not found.])]