summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/certmaster
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-27 21:40:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-27 21:40:48 (GMT)
commitf8de853dd6ca2b9f5bd5494e34973eab89e40fa5 (patch)
tree8aa1ce2d4651add1262fff2aee657e443013198a /abs/mv-core/certmaster
parent9828f9a5ca4c0b65c7d7dd2d7de9ee909ecaa6dd (diff)
downloadlinhes_pkgbuild-f8de853dd6ca2b9f5bd5494e34973eab89e40fa5.zip
linhes_pkgbuild-f8de853dd6ca2b9f5bd5494e34973eab89e40fa5.tar.gz
linhes_pkgbuild-f8de853dd6ca2b9f5bd5494e34973eab89e40fa5.tar.bz2
create dir for func/certmaster logging.
Diffstat (limited to 'abs/mv-core/certmaster')
-rw-r--r--abs/mv-core/certmaster/PKGBUILD5
-rwxr-xr-xabs/mv-core/certmaster/certmaster.install46
2 files changed, 48 insertions, 3 deletions
diff --git a/abs/mv-core/certmaster/PKGBUILD b/abs/mv-core/certmaster/PKGBUILD
index 96b8d2c..8158bd7 100644
--- a/abs/mv-core/certmaster/PKGBUILD
+++ b/abs/mv-core/certmaster/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=certmaster
pkgver=0.24
-pkgrel=5
+pkgrel=6
pkgdesc="certmaster"
url=""
license="gpl"
@@ -8,11 +8,10 @@ depends=(pyopenssl)
makedepends=()
conflicts=()
replaces=()
-backup=()
moddir="pkg/usr/lib/python2.5/site-packages/func/minion/modules/"
backup=('etc/certmaster/certmaster.conf' 'etc/certmaster/minion.conf')
-
+install=certmaster.install
source=($pkgname-$pkgver.tar.gz certmaster.conf minion.conf)
md5sums=()
arch=('i686')
diff --git a/abs/mv-core/certmaster/certmaster.install b/abs/mv-core/certmaster/certmaster.install
new file mode 100755
index 0000000..98c9215
--- /dev/null
+++ b/abs/mv-core/certmaster/certmaster.install
@@ -0,0 +1,46 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+/bin/true
+mkdir -p /var/log/certmaster
+}
+
+# arg 1: the new package version
+post_install() {
+ if [ ! -e /var/log/certmaster ]
+ then
+ mkdir -p /var/log/certmaster
+ fi
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+
+
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*