summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythweb
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:31 (GMT)
commit997dbedae9ea47fbb46ec15f8827cf1a8065c11e (patch)
treee20e579880f339682d8ede709369769269a365e0 /abs/mv-core/myth/stable/mythweb
parentda98b0f401f135cb5a04270dbfc46c5dafc43d9d (diff)
downloadlinhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.zip
linhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.tar.gz
linhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.tar.bz2
mv-core: bring it up to date so that it works again
Diffstat (limited to 'abs/mv-core/myth/stable/mythweb')
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/PKGBUILD34
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/dblogininit.inc6
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/mythweb.install37
-rwxr-xr-xabs/mv-core/myth/stable/mythweb/mythweblighttpd.patch13
4 files changed, 90 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythweb/PKGBUILD b/abs/mv-core/myth/stable/mythweb/PKGBUILD
new file mode 100755
index 0000000..52341a4
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythweb/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mythweb-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="mythweb"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686')
+depends=(php fcgi libmysqlclient )
+conflicts=('mythweb' 'mythweb-fixes')
+replaces=()
+backup=()
+install='mythweb.install'
+source=(mythweblighttpd.patch dblogininit.inc )
+md5sums=()
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+build() {
+echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#svn co http://cvs.mythtv.org/svn/trunk/mythtv
+#svn co http://cvs.mythtv.org/svn/trunk/mythplugins
+#svn co http://cvs.mythtv.org/svn/trunk/myththemes
+cd $startdir/src/mythplugins
+
+#take care of fing mythweb
+mkdir -p $startdir/pkg/data/srv/httpd/htdocs/
+cp -rp mythweb $startdir/pkg/data/srv/httpd/htdocs/
+cp -f $startdir/src/dblogininit.inc $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes/
+cd $startdir/pkg/data/srv/httpd/htdocs/mythweb/includes
+patch -p0 < $startdir/src/mythweblighttpd.patch
+
+chown -R nobody:nobody $startdir/pkg/data/srv/httpd/htdocs/mythweb
+chmod -R 775 $startdir/pkg/data/srv/httpd/htdocs/mythweb
+}
diff --git a/abs/mv-core/myth/stable/mythweb/dblogininit.inc b/abs/mv-core/myth/stable/mythweb/dblogininit.inc
new file mode 100755
index 0000000..c5395c5
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythweb/dblogininit.inc
@@ -0,0 +1,6 @@
+<?
+ $_SERVER["db_server"] = "localhost";
+ $_SERVER["db_name"] = "mythconverg";
+ $_SERVER["db_login"] = "mythtv";
+ $_SERVER["db_password"] = "mythtv";
+?>
diff --git a/abs/mv-core/myth/stable/mythweb/mythweb.install b/abs/mv-core/myth/stable/mythweb/mythweb.install
new file mode 100755
index 0000000..e135b6c
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythweb/mythweb.install
@@ -0,0 +1,37 @@
+
+# arg 1: the new package version
+pre_install () {
+/bin/true
+}
+
+post_install() {
+ #cp /etc/lighttpd/lighttpd.conf /tmp
+# sed -e "s/# .* \"mod_fastcgi\",/\"mod_fastcgi\"\,/g" /tmp/lighttpd.conf > /etc/lighttpd/lighttpd.conf
+ /bin/true
+
+}
+pre_upgrade () {
+ pre_install
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+/bint/true
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch b/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch
new file mode 100755
index 0000000..6403a88
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythweb/mythweblighttpd.patch
@@ -0,0 +1,13 @@
+--- database.php.orig 2007-12-31 21:25:30.000000000 +0000
++++ database.php 2007-12-31 21:25:50.000000000 +0000
+@@ -18,6 +18,10 @@
+ custom_error("Please install the MySQL libraries for PHP.\n"
+ .'The package is usually called something like php-mysql.');
+ }
++ if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {
++ require_once 'dblogininit.inc';
++ }
++
+
+ // No database connection info defined?
+ if (empty($_SERVER['db_server']) || empty($_SERVER['db_name']) || empty($_SERVER['db_login'])) {