summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/mythtv-status
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
commit1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e (patch)
treef336ee91ce16c6591fff50340562e07e15aa1a55 /abs/mv-core/mythtv-status
parent75b1bceb21faab32d8f519d6f7f7062a226f9047 (diff)
downloadlinhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.zip
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.gz
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.bz2
MythVantage specific pkgs
Diffstat (limited to 'abs/mv-core/mythtv-status')
-rwxr-xr-xabs/mv-core/mythtv-status/PKGBUILD21
-rw-r--r--abs/mv-core/mythtv-status/mythtv-status.cron4
-rw-r--r--abs/mv-core/mythtv-status/mythtv-status.install51
3 files changed, 76 insertions, 0 deletions
diff --git a/abs/mv-core/mythtv-status/PKGBUILD b/abs/mv-core/mythtv-status/PKGBUILD
new file mode 100755
index 0000000..4b1a007
--- /dev/null
+++ b/abs/mv-core/mythtv-status/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=mythtv-status
+pkgver=0.9.0
+pkgrel=5
+
+pkgdesc="displays myth status in motd"
+#depends=(perl-xml-libxml perl-mime-tools perl-mailtools perl-net-upnp)
+depends=(perl-xml-libxml perl-mime-parser perl-mailtools perl-net-upnp)
+arch=('i686')
+source=(mythtv-status.cron http://www.etc.gen.nz/projects/mythtv/tarballs/$pkgname-$pkgver.tar.gz)
+install=mythtv-status.install
+build() {
+ MVDIR=$startdir/pkg/usr/MythVantage/bin
+ mkdir -p $MVDIR
+ cd $startdir/src/$pkgname-$pkgver
+ cd bin
+ cp -p * $MVDIR/
+ cd $startdir
+ #install -m 0755 mythtv-status $MVDIR/mythtv-status
+ install -m 0755 mythtv-status.cron $MVDIR/mythtv-status.cron
+}
+
diff --git a/abs/mv-core/mythtv-status/mythtv-status.cron b/abs/mv-core/mythtv-status/mythtv-status.cron
new file mode 100644
index 0000000..088b87c
--- /dev/null
+++ b/abs/mv-core/mythtv-status/mythtv-status.cron
@@ -0,0 +1,4 @@
+#!/bin/bash
+. /etc/profile
+mythtv-status --noschedule-conflicts > /etc/motd
+
diff --git a/abs/mv-core/mythtv-status/mythtv-status.install b/abs/mv-core/mythtv-status/mythtv-status.install
new file mode 100644
index 0000000..304015a
--- /dev/null
+++ b/abs/mv-core/mythtv-status/mythtv-status.install
@@ -0,0 +1,51 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+/bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+MVDIR=/usr/MythVantage/bin
+
+
+ if [ ! -e /etc/cron.tenminutes ]
+ then
+ mkdir /etc/cron.tenminutes
+ fi
+ ln -s $MVDIR/mythtv-status.cron /etc/cron.tenminutes/mythtv-status.cron
+
+
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+
+
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*