summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/runit-scripts-mv/runitscripts/1
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
commitdb17e125c87e8056e2d0cdc5f1985ab62e713c84 (patch)
tree0e2c84550d6ffdfd33cc84c12c396db9ce3c987b /abs/mv-core/runit-scripts-mv/runitscripts/1
parente067093b13fb71f9d928ccf7a1b3ce6dd0124795 (diff)
parentd630a6ae3ada088453209270791ae281e2d5e393 (diff)
downloadlinhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.zip
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.gz
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/runit-scripts-mv/runitscripts/1')
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/116
1 files changed, 14 insertions, 2 deletions
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/1 b/abs/mv-core/runit-scripts-mv/runitscripts/1
index 748930f..6e4425d 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/1
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/1
@@ -1,14 +1,26 @@
#!/bin/bash
/etc/rc.sysinit
+. /etc/rc.conf
+. /etc/rc.d/functions
hostname `cat /etc/hostname`
/sbin/sysctl -p 2>/dev/null >/dev/null
-#/usr/bin/load-modules-mythvantage.sh
+#yes it's needed the 2nd time
+/usr/LH/bin/load-modules-mythvantage.sh >/dev/null
rm /etc/dhcpc/dhcpcd*.pid 2>/dev/null
rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
rm -f /etc/runit/reboot 2>/dev/null
+stat_busy "Starting network"
/etc/net/scripts/network.init start 2>/var/log/network.init.error >/var/log/network.init
+stat_done
/usr/sbin/ethtool -s eth0 wol g 2>/dev/null
/usr/sbin/ethtool -s eth1 wol g 2>/dev/null
/usr/sbin/ethtool -s eth2 wol g 2>/dev/null
+#user added stuff for level 1 of runit
+if [ -e /etc/runit/1.local ]
+then
+ #exec the file
+ stat_busy /etc/runit/1.local
+ /etc/runit/1.local
+ stat_done
+fi
-#/bin/su mythtv -c /usr/bin/grabkey.py 2>/dev/null 1>/devn/null &