summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
commit428e5178d79eb900bbe515665b2d6c6a4b0d0f89 (patch)
tree5cf7c10428f1d0afe62eeee70105bd447ea69b99 /abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run
parentf6276f03790fc2302054a8242339def7b6792557 (diff)
parent568da1387066e54f0eceb57fd8f53bd0eba87974 (diff)
downloadlinhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.zip
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.gz
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run')
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run7
1 files changed, 7 insertions, 0 deletions
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run
index 5697f6f..56f7ae6 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/evrouter/run
@@ -1,13 +1,20 @@
#!/bin/bash
. /etc/profile
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+
which evrouter >/dev/null 2>/dev/null
if [ $? = 0 ]
then
+
+ stat_runit "Starting evrouter"
ps -ef |grep -v grep|grep -q "Xvfb :50"
if [ ! $? = 0 ]
then
sv start Xvfb
fi
+
su mythtv -c "DISPLAY=localhost:50 evrouter -c /etc/evrouter.cfg -f /dev/input/event*"
fi