summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/tilda
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
commit1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e (patch)
treef336ee91ce16c6591fff50340562e07e15aa1a55 /abs/mv-core/tilda
parent75b1bceb21faab32d8f519d6f7f7062a226f9047 (diff)
downloadlinhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.zip
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.gz
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.bz2
MythVantage specific pkgs
Diffstat (limited to 'abs/mv-core/tilda')
-rwxr-xr-xabs/mv-core/tilda/PKGBUILD20
-rw-r--r--abs/mv-core/tilda/tilda.patch25
2 files changed, 45 insertions, 0 deletions
diff --git a/abs/mv-core/tilda/PKGBUILD b/abs/mv-core/tilda/PKGBUILD
new file mode 100755
index 0000000..351f944
--- /dev/null
+++ b/abs/mv-core/tilda/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: William Rea <sillywilly@gmail.com>
+pkgname=tilda
+pkgver=0.9.6
+pkgrel=8
+pkgdesc="Linux terminal based on classic terminals from first person shooter games."
+url="http://tilda.sourceforge.net"
+license="GPL"
+depends=('vte' 'confuse' 'libglade')
+makedepends=('gawk')
+source=(http://downloads.sourceforge.net/sourceforge/tilda/tilda-$pkgver.tar.gz tilda.patch)
+arch=('i686')
+build() {
+
+ cd $startdir/src/tilda-$pkgver/src
+ patch -p0 < $startdir/src/tilda.patch
+ cd $startdir/src/tilda-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/mv-core/tilda/tilda.patch b/abs/mv-core/tilda/tilda.patch
new file mode 100644
index 0000000..916a020
--- /dev/null
+++ b/abs/mv-core/tilda/tilda.patch
@@ -0,0 +1,25 @@
+--- tilda.c.orig 2008-02-06 21:52:53.000000000 +0000
++++ tilda.c 2008-08-04 04:52:46.000000000 +0000
+@@ -581,11 +581,12 @@
+ /* If the config file doesn't exist open up the wizard */
+ if (access (tw->config_file, R_OK) == -1)
+ {
++ //forget the wizard, just exit
++ exit (EXIT_SUCCESS);
+ /* We probably need a default key, too ... */
+ gchar *default_key = g_strdup_printf ("F%d", tw->instance+1);
+ config_setstr ("key", default_key);
+ g_free (default_key);
+-
+ need_wizard = TRUE;
+ }
+
+@@ -600,6 +601,8 @@
+
+ if (!ret)
+ {
++ //forget the wizard, just exit
++ exit (EXIT_SUCCESS);
+ /* The key was unbindable, so we need to show the wizard */
+ show_invalid_keybinding_dialog (NULL);
+ wizard (tw);