summaryrefslogtreecommitdiffstats
path: root/abs/mv-core
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:50 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:50 (GMT)
commitd615d8fb4dd78b2e51708b321ad77b6304458bfd (patch)
treeee1585afa44494632f0ebbee7c11e8c6ddf4fb52 /abs/mv-core
parente4e922e8206bce66217e08b678b10465036dd44c (diff)
parent982eaa1f1285ed3cb1022ec9520d1d6387b62e64 (diff)
downloadlinhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.zip
linhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.tar.gz
linhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core')
-rwxr-xr-xabs/mv-core/MythVantage-config/xconfig.sh95
-rwxr-xr-xabs/mv-core/MythVantage-system/firstboot.sh2
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runit.install3
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/lircd/finish6
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run12
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/ntpd/run4
6 files changed, 67 insertions, 55 deletions
diff --git a/abs/mv-core/MythVantage-config/xconfig.sh b/abs/mv-core/MythVantage-config/xconfig.sh
index 4984dc5..39b5ae6 100755
--- a/abs/mv-core/MythVantage-config/xconfig.sh
+++ b/abs/mv-core/MythVantage-config/xconfig.sh
@@ -8,9 +8,9 @@ function Xvalues {
echo $CMDLINE |grep -q forceXvesa
if [ $? = 0 ]
then
- VGACARDTYPE=vesa
+ VGACARDTYPE=vesa
else
- VGACARDTYPE=`lspci|grep -i vga|sort -r|head -n 1| cut -d: -f3|cut -d" " -f 2`
+ VGACARDTYPE=`lspci|grep -i vga|sort -r|head -n 1| cut -d: -f3|cut -d" " -f 2`
fi
echo $VGACARDTYPE
currentmode=`cat $BASE/etc/X11/xorg.conf |grep Modes|awk -Fs ' { print $2 } '`
@@ -28,12 +28,12 @@ then
else
echo "Didn't find the file"
echo "Copy your config file to $BASE/data/home/mythtv/templates/xorg.use " >> $XORG_CONF
- fi
+ fi
else
setupAdvancedX
fi
else
- setupX
+ setupX
fi
}
@@ -65,27 +65,27 @@ echo "#doing the advanced" > /tmp/options
ML="\t Modes ${Xres}"
else
- ML="\t Modes \"${Xres}\""
+ ML="\t Modes \"${Xres}\""
fi
echo $ML
case $Xcardtype in
NVIDIA|nVidia )
- case $Xconnection in
+ case $Xconnection in
DVI) ConnectedMonitor=DFP ;;
vga) ConnectedMonitor=CRT;;
Auto) ConnectedMonitor=Auto;;
TV) ConnectedMonitor=TV
- echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
- echo "Option \"TVOutFormat\" \"$XTVconnection\"" >> /tmp/options
- ;;
+ echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
+ echo "Option \"TVOutFormat\" \"$XTVconnection\"" >> /tmp/options
+ ;;
esac
if [ $ConnectedMonitor = Auto ]
then
- echo "auto connection"
+ echo "auto connection"
else
- echo "Option \"ConnectedMonitor\" \"$ConnectedMonitor\"" >> /tmp/options
- echo "Option \"FlatPanelProperties\" \"Scaling = centered, Dithering = enabled\"" >> /tmp/options
+ echo "Option \"ConnectedMonitor\" \"$ConnectedMonitor\"" >> /tmp/options
+ echo "Option \"FlatPanelProperties\" \"Scaling = centered, Dithering = enabled\"" >> /tmp/options
echo "Option \"DigitalVibrance\" \"0\"" >> /tmp/options
fi
@@ -96,7 +96,7 @@ echo "#doing the advanced" > /tmp/options
DS=" DisplaySize $XDisplaysize"
HS=" HorizSync $XHsync"
VR=" VertRefresh $XVrefresh"
- else
+ else
EDIDvalue=false
EDIDFREQ=true
DS="# Display size edid used "
@@ -109,46 +109,46 @@ echo "#doing the advanced" > /tmp/options
sed -e "s/^.*Modes.*$/${ML}/" \
- -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
- -e "s/^.*DisplaySize.*$/ $DS/" \
- -e "s/^#.*HorizSync.*$/ $HS/g" \
- -e "s/^#.*VertRefresh.*$/ $VR/g" \
- -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.nvidia > $XORG_CONF
-
- ;;
- ati|ATI)
- case $Xconnection in
+ -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
+ -e "s/^.*DisplaySize.*$/ $DS/" \
+ -e "s/^#.*HorizSync.*$/ $HS/g" \
+ -e "s/^#.*VertRefresh.*$/ $VR/g" \
+ -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.nvidia > $XORG_CONF
+
+ ;;
+ ati|ATI)
+ case $Xconnection in
DVI) ConnectedMonitor="tmds1,nocrt1,notv";;
VGA) ConnectedMonitor="crt1,notmds1,notv" ;;
TV) ConnectedMonitor="tv,nocrt1,notmds1"
- echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
- echo "Option \"TVFormat\" \"$XTVconnection\"" >> /tmp/options
- ;;
+ echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
+ echo "Option \"TVFormat\" \"$XTVconnection\"" >> /tmp/options
+ ;;
- esac
+ esac
- if [ x$XignoreEDID = x1 ]
+ if [ x$XignoreEDID = x1 ]
then
DS=" DisplaySize $XDisplaysize"
HS=" HorizSync $XHsync"
VR=" VertRefresh $XVrefresh"
- else
+ else
DS="# Display size edid used "
HS="#Hsync edid used "
VR="#Vertrefresh edid used "
fi
- echo "Option \"ForceMonitors\" \"$ConnectedMonitor\"" >> /tmp/options
+ echo "Option \"ForceMonitors\" \"$ConnectedMonitor\"" >> /tmp/options
- sed -e "s/^.*Modes.*$/\t $ML/" \
- -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
- -e "s/^.*DisplaySize.*$/ $DS/" \
- -e "s/^#.*HorizSync.*$/ $HS/g" \
- -e "s/^#.*VertRefresh.*$/ $VR/g" \
- -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.ati > $XORG_CONF
- ;;
+ sed -e "s/^.*Modes.*$/\t $ML/" \
+ -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
+ -e "s/^.*DisplaySize.*$/ $DS/" \
+ -e "s/^#.*HorizSync.*$/ $HS/g" \
+ -e "s/^#.*VertRefresh.*$/ $VR/g" \
+ -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.ati > $XORG_CONF
+ ;;
via|VIA|Via) echo "no via here"
;;
@@ -178,7 +178,7 @@ function setupX {
fi
;;
VMware )
- sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vmware > $XORG_CONF
+ sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vmware > $XORG_CONF
;;
VIA )
@@ -190,7 +190,7 @@ function setupX {
fi
;;
- Intel)
+ Intel)
sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.intel > $XORG_CONF
if [ ! x$TESTMODE = "xtest" ]
then
@@ -199,15 +199,16 @@ function setupX {
fi
;;
- vesa) sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vesa > $XORG_CONF
-
-
- *) #XCONF=`hwd -x |grep etc`
- XCONF=`hwd -x |grep etc|tr -d [:cntrl:]|cut -d\/ -f 2-`
-
-
- cat /$XCONF |grep -v Modes | sed -e '/Depth 16/a Modes "800x600"' -e 's/dev\/mouse/dev\/psaux/g'> $XORG_CONF
- ;;
+ vesa) sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vesa > $XORG_CONF
+ ;;
+ *) #XCONF=`hwd -x |grep etc`
+ #XCONF=`hwd -x |grep etc|tr -d [:cntrl:]|cut -d\/ -f 2-`
+ XCONF=/root/xorg.conf.new
+ X -configure
+ echo $XORG_CONF
+ grep -v Modes $XCONF | sed -e '/Depth.*16/a Modes "800x600"' -e '/Depth.*24/a Modes "800x600"' -e 's/dev\/mouse/dev\/psaux/g'> $XORG_CONF
+ rm -f $XCONF
+ ;;
esac
fi
diff --git a/abs/mv-core/MythVantage-system/firstboot.sh b/abs/mv-core/MythVantage-system/firstboot.sh
index 366874a..b329f5a 100755
--- a/abs/mv-core/MythVantage-system/firstboot.sh
+++ b/abs/mv-core/MythVantage-system/firstboot.sh
@@ -3,7 +3,7 @@
ATTEMPT=0
function try_smolt {
((ATTEMPT=ATTEMPT+1))
- echo $ATTEMPT
+# echo $ATTEMPT
status=$(echo "jump mythsmolt" | telnet localhost 6546 2>&1)
echo $status|grep -q refused
status=$?
diff --git a/abs/mv-core/runit-scripts-mv/runit.install b/abs/mv-core/runit-scripts-mv/runit.install
index 4652368..adaf5ed 100755
--- a/abs/mv-core/runit-scripts-mv/runit.install
+++ b/abs/mv-core/runit-scripts-mv/runit.install
@@ -23,8 +23,7 @@ fi
post_install () {
mkdir /var/service
- ln -s /etc/sv/tty* /var/service
- servicelist="acpid cron frontend lircd ntpd alsa-utils avahi dbus portmap sshd"
+ servicelist="acpid cron frontend lircd ntpd alsa-utils avahi dbus portmap sshd tty2 tty3"
for i in $servicelist
do
ln -s /etc/sv/$i /var/service/$i
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/finish b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/finish
index 3545b07..754bca1 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/finish
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/finish
@@ -1,12 +1,12 @@
#!/bin/bash
-killall -9 lircd
+killall -9 lircd 2>/dev/null
rm -f /var/run/lirc*.pid
+[ -e /etc/sv/lircd/.runtime ] || mkdir -p /etc/sv/lircd/.runtime
touch /etc/sv/lircd/.runtime/`date +%s`
numfiles=`/usr/bin/file_time_offset.py -s4 -d/etc/sv/lircd/.runtime `
if [ $numfiles -gt 3 ]
then
- rm -f /etc/sv/lircd/.runtime/*
- ls -la /etc/sv/lircd/.runtime/*
+ rm -f /etc/sv/lircd/.runtime/* 2>/dev/null
sv stop lircd
echo "lircd is not able to start, disabling it"
fi
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
index 4457b37..0adfdc1 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
@@ -2,6 +2,17 @@
exec 2>&1
run_lircd2=false
. /etc/systemconfig
+[ -e /etc/sv/lircd/.runtime ] || mkdir -p /etc/sv/lircd/.runtime
+
+function dvico_detect {
+
+
+ if [ x$Remotetype = "dvico" ]
+ then
+ DEVICE="/dev/usb/hiddev0"
+ fi
+}
+
function imon_detect {
if [ -e /dev/lirc_imon ]
then
@@ -27,6 +38,7 @@ case $ReceiverType in
DEVICE=`ls /dev/lirc[0-9] 2>/dev/null |sort |sed '/./,$!d'|head -n 1 `
imon_detect
+ dvico_detect
;;
esac
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/ntpd/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/ntpd/run
index 97302f1..65e551c 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/ntpd/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/ntpd/run
@@ -1,3 +1,3 @@
#!/bin/sh
-ntpdate pool.ntp.org
-exec ntpd -n -p /var/run/ntpd.pid
+/usr/bin/ntpdate pool.ntp.org
+exec /usr/bin/ntpd -n -p /var/run/ntpd.pid