summaryrefslogtreecommitdiffstats
path: root/abs/mv-core
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-13 23:50:06 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-13 23:50:06 (GMT)
commited42012166c5e0884049af699fa82e2ee8b130ed (patch)
tree84fd1cc78b685e9581aa55099b3b898301ff438b /abs/mv-core
parent2cad5b74898cc22dedf4c3ccc2d0de2906a5dfd3 (diff)
parent13b5221b802174391f7d9c7da28785520283deec (diff)
downloadlinhes_pkgbuild-ed42012166c5e0884049af699fa82e2ee8b130ed.zip
linhes_pkgbuild-ed42012166c5e0884049af699fa82e2ee8b130ed.tar.gz
linhes_pkgbuild-ed42012166c5e0884049af699fa82e2ee8b130ed.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core')
-rwxr-xr-xabs/mv-core/MythVantage-config/install_functions.sh6
-rwxr-xr-xabs/mv-core/MythVantage-config/mv_common.py1
-rwxr-xr-xabs/mv-core/MythVantage-config/mv_network.py5
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/nfsd/run2
4 files changed, 9 insertions, 5 deletions
diff --git a/abs/mv-core/MythVantage-config/install_functions.sh b/abs/mv-core/MythVantage-config/install_functions.sh
index 72023bd..83a2bed 100755
--- a/abs/mv-core/MythVantage-config/install_functions.sh
+++ b/abs/mv-core/MythVantage-config/install_functions.sh
@@ -16,8 +16,8 @@ found_remote=1
function update_db_settings () {
printhl " setting database value $1 to $2 for $hostname"
- $MYSQLCMD_C "delete from settings where value='${1}' and hostname=\"$hostname\";"
- $MYSQLCMD_C "REPLACE INTO settings set value='${1}', data='${2}' , hostname=\"$hostname\";"
+ $MYSQLCMD_C "delete from settings where value='${1}' and hostname=\"$hostname\";" 2>/dev/null
+ $MYSQLCMD_C "REPLACE INTO settings set value='${1}', data='${2}' , hostname=\"$hostname\";" 2>/dev/null
}
function random_theme () {
@@ -296,7 +296,7 @@ function request_dhcp(){
update_db_settings HostNETMASK$ndev "$TEMPVAR"
TEMPVAR=`grep new_routers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
update_db_settings HostGW$ndev "$TEMPVAR"
- TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
+ TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut -d\= -f2| tr -d \"|tr -d \'|cut -d" " -f 1`
update_db_settings HostDNS$ndev "$TEMPVAR"
fi
fi
diff --git a/abs/mv-core/MythVantage-config/mv_common.py b/abs/mv-core/MythVantage-config/mv_common.py
index f18e02b..a492597 100755
--- a/abs/mv-core/MythVantage-config/mv_common.py
+++ b/abs/mv-core/MythVantage-config/mv_common.py
@@ -44,6 +44,7 @@ def add_service(daemon):
def remove_service(daemon):
logging.info(" Removing service %s",daemon)
+ stop_service(daemon)
cmd = "remove_service.sh %s" %daemon
runcmd(cmd)
diff --git a/abs/mv-core/MythVantage-config/mv_network.py b/abs/mv-core/MythVantage-config/mv_network.py
index 3f8de3b..b80e4cc 100755
--- a/abs/mv-core/MythVantage-config/mv_network.py
+++ b/abs/mv-core/MythVantage-config/mv_network.py
@@ -263,7 +263,10 @@ def setup_interface(netdev,systemconfig):
optionfile=etcnetdir+"/"+netdev+"/options"
if not os.path.exists(optionfile):
- os.makedirs(etcnetdir+"/"+netdev)
+ try:
+ os.makedirs(etcnetdir+"/"+netdev)
+ except:
+ pass
mv_common.cp_and_log(systemconfig["TEMPLATES"]+"/etcnet/eth/options", optionfile)
if netinfo["isactive"] == "1" :
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/nfsd/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/nfsd/run
index 3b63077..9665066 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/nfsd/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/nfsd/run
@@ -16,7 +16,7 @@ source /etc/conf.d/nfs
# start some nfsd threads
printhl " Using ${NFSD_OPTS} "
-/usr/sbin/rpc.nfsd -p ${NFSD_OPTS} >/dev/null 2>/dev/null
+/usr/sbin/rpc.nfsd ${NFSD_OPTS} >/dev/null 2>/dev/null
# since we are running kernel 2.6 we should also
# mount the nfsd virtual filesystem