summaryrefslogtreecommitdiffstats
path: root/abs/mv-core
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-02 07:36:39 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-02 07:36:39 (GMT)
commit27ffd698803e8cf434d5960a5a7164419be035be (patch)
tree5bbd1f8c75cda6de4070df8e4a5bd09e8b4823ba /abs/mv-core
parentd77878f24a8cfa23eb1b3abbcdac0f0f8c0376c2 (diff)
parent598c3f886f1629aae5200495eaeb5df0215d0d62 (diff)
downloadlinhes_pkgbuild-27ffd698803e8cf434d5960a5a7164419be035be.zip
linhes_pkgbuild-27ffd698803e8cf434d5960a5a7164419be035be.tar.gz
linhes_pkgbuild-27ffd698803e8cf434d5960a5a7164419be035be.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core')
-rw-r--r--abs/mv-core/MythVantage-config/networkconfig.sh8
1 files changed, 6 insertions, 2 deletions
diff --git a/abs/mv-core/MythVantage-config/networkconfig.sh b/abs/mv-core/MythVantage-config/networkconfig.sh
index b4ffd5c..5611265 100644
--- a/abs/mv-core/MythVantage-config/networkconfig.sh
+++ b/abs/mv-core/MythVantage-config/networkconfig.sh
@@ -51,8 +51,11 @@ function change_iface_state () {
sed -i -e 's/^DISABLED=.*$/DISABLED=no/g' $ETCNETDIR/$1/options
else
echo "setting $1 to inactive"
- sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' $ETCNETDIR/$1/options
- sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' $ETCNETDIR/$1/options
+ if [ -e $ETCNETDIR/$1/options ]
+ then
+ sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' $ETCNETDIR/$1/options
+ sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' $ETCNETDIR/$1/options
+ fi
/sbin/ifconfig $1 down
ip address flush $1
fi
@@ -262,6 +265,7 @@ function start_network {
if [ ! $USEVNC = 0 ]
then
/etc/net/scripts/network.init reload
+ /etc/net/scripts/network.init restart
else
echo "VNC/NETBOOT in use, will NOT restart network"
fi