summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/libcl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/libcl
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/libcl')
-rw-r--r--abs/not_built/core/libcl/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/not_built/core/libcl/PKGBUILD b/abs/not_built/core/libcl/PKGBUILD
new file mode 100644
index 0000000..cd9e82e
--- /dev/null
+++ b/abs/not_built/core/libcl/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+#Maintainer: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=libcl
+pkgver=1.0
+_pkgver=275.19
+pkgrel=1
+pkgdesc="OpenCL library and ICD loader from NVIDIA"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('gcc-libs')
+license=('custom')
+options=('!strip')
+
+if [ "$CARCH" = "i686" ]; then
+ _arch='x86'
+ _pkg="NVIDIA-Linux-${_arch}-${_pkgver}"
+ source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${_pkgver}/${_pkg}.run")
+ md5sums=('9e74b1913ff5eb6786600d47b64ba57d')
+elif [ "$CARCH" = "x86_64" ]; then
+ _arch='x86_64'
+ _pkg="NVIDIA-Linux-${_arch}-${_pkgver}-no-compat32"
+ source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${_pkgver}/${_pkg}.run")
+ md5sums=('45a6074db3efe961d025afa7a89fa036')
+fi
+build() {
+ cd $srcdir
+ sh ${_pkg}.run --extract-only
+}
+
+package() {
+ cd $srcdir/${_pkg}
+ install -D -m755 libOpenCL.so.1.0.0 $pkgdir/usr/lib/libOpenCL.so.1.0.0
+ ln -s /usr/lib/libOpenCL.so.1.0.0 $pkgdir/usr/lib/libOpenCL.so.1
+ ln -s /usr/lib/libOpenCL.so.1 $pkgdir/usr/lib/libOpenCL.so
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums=('9e74b1913ff5eb6786600d47b64ba57d')