summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/linuxtv-dvb-apps/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/linuxtv-dvb-apps/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/linuxtv-dvb-apps/PKGBUILD')
-rw-r--r--abs/not_built/core/linuxtv-dvb-apps/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/not_built/core/linuxtv-dvb-apps/PKGBUILD b/abs/not_built/core/linuxtv-dvb-apps/PKGBUILD
new file mode 100644
index 0000000..7dd5b29
--- /dev/null
+++ b/abs/not_built/core/linuxtv-dvb-apps/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+# Contributor: Camille Moncelier <pix@devlife.org>
+
+pkgname=linuxtv-dvb-apps
+pkgver=1.1.1
+pkgrel=4
+_hgrev=68d20621d93a
+pkgdesc='Viewer programs for DVB cards'
+arch=('i686' 'x86_64')
+url='http://www.linuxtv.org/'
+license=('GPL')
+install=linuxtv-dvb-apps.install
+#source=(http://www.linuxtv.org/download/dvb/$pkgname-$pkgver.tar.bz2)
+source=("http://linuxtv.org/hg/dvb-apps/archive/${_hgrev}.tar.bz2")
+
+build() {
+ cd dvb-apps-${_hgrev}
+
+ rm -rf include
+
+ make -C lib
+
+ make -C util
+}
+
+package() {
+ cd dvb-apps-${_hgrev}
+
+ make -C lib DESTDIR=${pkgdir} install
+
+ make -C util DESTDIR=${pkgdir} install
+
+ chmod 755 ${pkgdir}/usr/lib/*.so*
+}
+
+md5sums=('6e4bc8e5b22609b212f968c7d88e90ab')