summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD')
-rw-r--r--abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD b/abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD
new file mode 100644
index 0000000..e667f5e
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-text-bidi/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-text-bidi
+pkgver=0.03
+pkgrel=3
+pkgdesc="Unicode bidi algorithm-libfribidi interface"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~KAMENSKY/Text-Bidi"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'fribidi')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/K/KA/KAMENSKY/Text-Bidi-$pkgver.tar.gz)
+md5sums=('93e124628ff2983e32ac478f25f8d627')
+
+build() {
+ cd $startdir/src/Text-Bidi-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}