summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD')
-rwxr-xr-xabs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD b/abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD
new file mode 100755
index 0000000..34757a3
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-xml-xql/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: ndlarsen <ndlarsen@gmail.com>
+# Comment: Based on PKGBUILDs from the perlcpan repo by Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-xml-xql
+pkgver=0.68
+pkgrel=1
+pkgdesc="A perl module for querying XML tree structures with XQL"
+arch=('i686')
+url="http://search.cpan.org/dist/XML-XQL/lib/XML/XQL.pm"
+license=('GPL Artistic')
+depends=('perl-parse-yapp' 'perl-xml-dom' 'perl-xml-parser' 'perl-date-manip')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+groups=()
+options=(docs !emptydirs)
+install=
+noextract=()
+source=(http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-XQL-$pkgver.tar.gz)
+md5sums=('bb84096fdf8bcc96a35971539ce8c19e')
+
+build() {
+
+ cd $startdir/src/XML-XQL-$pkgver
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor MAN1ext=1p MAN3EXT=3pm
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -name 'perllocal.pod' -exec rm '{}' \;
+
+}
+# $Id$ \ No newline at end of file