summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base')
-rw-r--r--abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base b/abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base
new file mode 100644
index 0000000..1711062
--- /dev/null
+++ b/abs/not_built/core/plextor-convertX-driver/.svn/text-base/PKGBUILD.svn-base
@@ -0,0 +1,31 @@
+
+
+pkgname=plextor-convertX-driver
+pkgver=0.9.8
+pkgrel=3
+_kernver=2.6.17-STB
+pkgdesc="ivtv - Drivers for many types of PVR cards"
+arch=(i686 x86_64)
+url="http://ivtvdriver.org"
+install="convertX.install"
+source=("http://oss.wischip.com/wis-go7007-linux-$pkgver.tar.bz2" "wis-go-0.9.8-2.6.17.patch")
+depends=(gcc 'udev>=070' 'fxload')
+
+
+build() {
+
+ # SET UP
+ patch -p0 < wis-go-0.9.8-2.6.17.patch
+ cd $startdir/src/wis-go7007-linux-0.9.8|| return 1
+
+ # build
+ make clean || return 1
+ make || return 1
+ mkdir -p $startdir/pkg/usr/src/linux-$_kernver/include/linux
+ mkdir -p $startdir/pkg/etc/udev/rules.d
+ mkdir -p $startdir/pkg/usr/bin
+ # install
+ make DESTDIR=$startdir/pkg install || return 1
+ install -m755 apps/gorecord $startdir/pkg/usr/bin/gorecord
+ install -m755 apps/modet $startdir/pkg/usr/bin/modet
+}