summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/mmv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/mmv
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/mmv')
-rw-r--r--abs/not_built/extra/community/mmv/PKGBUILD35
-rw-r--r--abs/not_built/extra/community/mmv/mmv.install19
2 files changed, 54 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/mmv/PKGBUILD b/abs/not_built/extra/community/mmv/PKGBUILD
new file mode 100644
index 0000000..0ccec1b
--- /dev/null
+++ b/abs/not_built/extra/community/mmv/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: blue_lizard lizard@blue.dyn-o-saur.com
+
+pkgname=mmv
+pkgver=1.01b.orig
+pkgrel=1
+pkgdesc="multiple move files"
+depends=('glibc' 'sed')
+conflicts=()
+backup=()
+source=(http://ftp.de.debian.org/debian/pool/main/m/mmv/mmv_1.01b.orig.tar.gz http://ftp.de.debian.org/debian/pool/main/m/mmv/mmv_1.01b-14.diff.gz)
+md5sums=('1b2135ab2f17bdfa9e08debbb3c46ad8' 'a69eff7501e63c0bd1fcd231bf6949f1')
+url="http://linux.maruhn.com/sec/mmv.html"
+license="GPL"
+install=$pkgname.install
+arch=('i686')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p1 < ../mmv_1.01b-14.diff
+ cat Makefile | sed -e "s/LDFLAGS.\s=-s -N/LDFLAGS =-s/g" > /tmp/Makefile
+ mv /tmp/Makefile ./
+ make || return 1
+ mkdir -p $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/usr/man/man1
+ make DESTDIR=$startdir/pkg install
+ chmod 644 $startdir/pkg/usr/man/man1/mmv.1
+ cd $startdir/pkg/usr/bin
+ ln -s mmv mcp
+ ln -s mmv mad
+ ln -s mmv mln
+ cd $startdir/pkg/usr/man/man1/
+ ln -s mmv.1 mcp.1
+ ln -s mmv.1 mad.1
+ ln -s mmv.1 mln.1
+}
diff --git a/abs/not_built/extra/community/mmv/mmv.install b/abs/not_built/extra/community/mmv/mmv.install
new file mode 100644
index 0000000..9b23e48
--- /dev/null
+++ b/abs/not_built/extra/community/mmv/mmv.install
@@ -0,0 +1,19 @@
+# arg 1: the new package version
+post_install() {
+ echo ">>>"
+ echo ">>>"
+ echo ">>>"
+ echo ">>> many thanks to the debian people who provide the sources"
+ echo ">>>"
+}
+
+# arg 1: the old package version
+post_remove() {
+ echo ">>>"
+ echo ">>>"
+ echo ">>>"
+}
+
+op=$1
+shift
+$op $*