summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/portaudio
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/portaudio
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/portaudio')
-rw-r--r--abs/not_built/extra/community/portaudio/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/portaudio/PKGBUILD b/abs/not_built/extra/community/portaudio/PKGBUILD
new file mode 100644
index 0000000..1872b94
--- /dev/null
+++ b/abs/not_built/extra/community/portaudio/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 55258 2011-09-07 18:41:32Z ebelanger $
+# Based on 'portaudio' package - Eric Belanger <eric@archlinux.org>
+# Last/Most-Recent Contributor: Darwin Bautista <djclue917@gmail.com>
+# Maintainer: Bob Finch <w9ya@qrparci.net>
+
+pkgname=portaudio
+pkgver=19_20110326
+pkgrel=1
+pkgdesc="A free, cross-platform, open source, audio I/O library"
+arch=('i686' 'x86_64')
+url="http://www.portaudio.com/"
+license=('custom')
+depends=('jack')
+options=('!libtool')
+source=(http://www.portaudio.com/archives/pa_stable_v$pkgver.tgz)
+md5sums=('8f266ce03638419ef46e4efcb0fabde6')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}