summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/conky
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/conky
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/conky')
-rw-r--r--abs/not_built/extra/conky/PKGBUILD47
-rw-r--r--abs/not_built/extra/conky/current-power.patch12
2 files changed, 59 insertions, 0 deletions
diff --git a/abs/not_built/extra/conky/PKGBUILD b/abs/not_built/extra/conky/PKGBUILD
new file mode 100644
index 0000000..d542937
--- /dev/null
+++ b/abs/not_built/extra/conky/PKGBUILD
@@ -0,0 +1,47 @@
+# $Id$
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=conky
+pkgver=1.8.1
+pkgrel=3
+pkgdesc='An advanced, highly configurable system monitor for X based on torsmo'
+arch=('i686' 'x86_64')
+url='http://conky.sourceforge.net/'
+license=('custom')
+replaces=('torsmo')
+makedepends=('pkg-config')
+depends=('alsa-lib' 'libxml2' 'curl' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2')
+backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'current-power.patch')
+
+sha1sums=('06bbe9b7eed8603fa7a971b27c5c61f38424ac6f'
+ '2eeef0cc5a0b612826b2a7f0b43b7a3b7e10bf0b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 < ../current-power.patch # See FS#21984
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-ibm \
+ --enable-curl \
+ --enable-rss \
+ --enable-weather-xoap \
+ --enable-imlib2 \
+ --disable-lua \
+ --enable-wlan \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/not_built/extra/conky/current-power.patch b/abs/not_built/extra/conky/current-power.patch
new file mode 100644
index 0000000..1e7cf5a
--- /dev/null
+++ b/abs/not_built/extra/conky/current-power.patch
@@ -0,0 +1,12 @@
+diff -aur old/src/linux.c new/src/linux.c
+--- old/src/linux.c 2010-10-05 23:29:36.000000000 +0200
++++ new/src/linux.c 2010-12-06 22:18:59.346667183 +0100
+@@ -1671,6 +1671,8 @@
+ the tradition! */
+ else if (strncmp(buf, "POWER_SUPPLY_CURRENT_NOW=", 25) == 0)
+ sscanf(buf, "POWER_SUPPLY_CURRENT_NOW=%d", &present_rate);
++ else if (strncmp(buf, "POWER_SUPPLY_POWER_NOW=", 23) == 0)
++ sscanf(buf, "POWER_SUPPLY_POWER_NOW=%d", &present_rate);
+ else if (strncmp(buf, "POWER_SUPPLY_ENERGY_NOW=", 24) == 0)
+ sscanf(buf, "POWER_SUPPLY_ENERGY_NOW=%d", &remaining_capacity);
+ else if (strncmp(buf, "POWER_SUPPLY_ENERGY_FULL=", 25) == 0)