summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/gnuplot/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/gnuplot/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/gnuplot/PKGBUILD')
-rw-r--r--abs/not_built/extra/gnuplot/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/not_built/extra/gnuplot/PKGBUILD b/abs/not_built/extra/gnuplot/PKGBUILD
new file mode 100644
index 0000000..3b04bde
--- /dev/null
+++ b/abs/not_built/extra/gnuplot/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: damir <damir@archlinux.org>
+# Contributor: Niklas Volbers <mithrandir42@web.de>
+
+pkgname=gnuplot
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Command-line driven interactive data and function plotting utility"
+url="http://www.gnuplot.info"
+depends=('gd>=2.0.29' 'wxgtk' 'libjpeg>=7')
+makedepends=('texinfo')
+license='custom'
+arch=('i686')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --libexecdir=/usr/bin \
+ --with-readline=gnu \
+ --enable-history-file \
+ --with-x
+
+ make X11_DRIVER_DIR='/usr/bin' || return 1
+
+ make DESTDIR=$startdir/pkg \
+ libexecdir=/usr/bin \
+ pkglibexecdir=/usr/bin install
+
+ install -D $startdir/src/$pkgname-$pkgver/Copyright $startdir/pkg/usr/share/licenses/custom/gnuplot/Copyright
+}
+md5sums=('e708665bd512153ad5c35252fe499059')