summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/monitorix/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/monitorix/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/monitorix/PKGBUILD')
-rw-r--r--abs/not_built/extra/monitorix/PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/abs/not_built/extra/monitorix/PKGBUILD b/abs/not_built/extra/monitorix/PKGBUILD
new file mode 100644
index 0000000..d2dceec
--- /dev/null
+++ b/abs/not_built/extra/monitorix/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: graysky <graysky AT archlinux dot us>
+# Contributor: res <andres87p gmail>
+
+pkgname=monitorix
+pkgver=1.5.2
+pkgrel=1
+pkgdesc='A lightweight system monitoring tool that uses rrd databases.'
+arch=(any)
+url=http://www.$pkgname.org/
+license=(GPL)
+depends=('rrdtool' 'perl-libwww')
+optdepends=('lm_sensors: enable support for system temp monitoring'
+'hddtemp: enable support for hdd temp monitoring'
+'metamail: enable support for reports via system mail')
+
+backup=(etc/$pkgname.conf)
+source=($url$pkgname-$pkgver.tar.gz
+ monitorix.rc.d)
+install=('readme.install')
+
+build() {
+ cd $pkgname-$pkgver
+
+ install -D $pkgname.pl $pkgdir/usr/sbin/$pkgname.pl
+ install -D ../$pkgname.rc.d $pkgdir/etc/rc.d/$pkgname
+
+# use Arch defaults
+ sed -e '/^our $OSTYPE/ s,RHFC,Arch,' \
+ -e '/^our @HDDTEMP_LIST/ s,hda,sda,' < $pkgname.conf \
+ > $pkgdir/etc/$pkgname.conf
+ mkdir -p $pkgdir/var/lib/$pkgname/usage
+ cp -r reports $pkgdir/var/lib/$pkgname
+
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ cp Changes $pkgname-apache.conf $pkgname-alert.sh README README.nginx TODO \
+ $pkgdir/usr/share/doc/$pkgname
+
+ install -dm777 $pkgdir/srv/http/$pkgname/imgs
+ cp {logo_bot,logo_top,${pkgname}ico}.png $pkgdir/srv/http/$pkgname
+
+ install -D $pkgname.cgi $pkgdir/srv/http/cgi-bin/$pkgname.cgi
+
+ gzip -9 man/man5/$pkgname.conf.5
+ install -Dm644 man/man5/$pkgname.conf.5.gz $pkgdir/usr/share/man/man5/$pkgname.conf.5.gz
+}
+sha256sums=('3d025d097fe8dd458501b8cf3345b80b1b66625ae257e21452b95d1596ec5b6d'
+ 'f9ba4e09f8e583808bc9fa5476ddac067182799512e103ea40565b7da47dbab6')