summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/numlockx/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/numlockx/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/numlockx/PKGBUILD')
-rw-r--r--abs/not_built/extra/numlockx/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/not_built/extra/numlockx/PKGBUILD b/abs/not_built/extra/numlockx/PKGBUILD
new file mode 100644
index 0000000..172cceb
--- /dev/null
+++ b/abs/not_built/extra/numlockx/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 19225 2008-11-17 22:12:15Z thayer $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+
+pkgname=numlockx
+pkgver=1.1
+pkgrel=4
+pkgdesc="Turns on the numlock key in X11"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://ktown.kde.org/~seli/numlockx/"
+depends=('libxtst')
+source=(http://ktown.kde.org/~seli/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('127d9dfbbbe6dbec62cc78db340f913c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr x_includes=/usr/include/X11 \
+ x_libraries=/usr/lib || return 1
+ make || return 1
+ make prefix=$pkgdir/usr install || return 1
+
+ # Install the custom MIT license
+ install -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE || return 1
+}