summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/perl-time-hires
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/perl-time-hires
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/perl-time-hires')
-rw-r--r--abs/not_built/extra/perl-time-hires/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/not_built/extra/perl-time-hires/PKGBUILD b/abs/not_built/extra/perl-time-hires/PKGBUILD
new file mode 100644
index 0000000..2e01636
--- /dev/null
+++ b/abs/not_built/extra/perl-time-hires/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 82203 2010-06-09 09:42:03Z jgc $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: mezcal <fila at pruda dot com>
+
+pkgname=perl-time-hires
+pkgver=1.9721
+pkgrel=2
+pkgdesc="Perl module: high resolution time, sleep, and alarm"
+arch=('i686' 'x86_64')
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/Time-HiRes/"
+depends=('perl')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/J/JH/JHI/Time-HiRes-${pkgver}.tar.gz)
+md5sums=('bf09911a36b9481537c8e0d28fbb3aaf')
+
+build() {
+ cd "${srcdir}/Time-HiRes-${pkgver}"
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make test || return 1
+ make install DESTDIR="${pkgdir}" || return 1
+}
+