summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/phpmyadmin
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/phpmyadmin
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/phpmyadmin')
-rw-r--r--abs/not_built/extra/phpmyadmin/PKGBUILD48
-rw-r--r--abs/not_built/extra/phpmyadmin/__changelog2
2 files changed, 50 insertions, 0 deletions
diff --git a/abs/not_built/extra/phpmyadmin/PKGBUILD b/abs/not_built/extra/phpmyadmin/PKGBUILD
new file mode 100644
index 0000000..f3b9be3
--- /dev/null
+++ b/abs/not_built/extra/phpmyadmin/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD 34046 2010-12-01 14:03:04Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: tobias <tobias@archlinux.org>
+# Committer: Manolis Tzanidakis <manolis@archlinux.org>
+# Contributor: Simon Lackerbauer <calypso "at" strpg.org>
+
+pkgname=phpmyadmin
+pkgver=3.3.8.1
+pkgrel=1
+pkgdesc="A PHP and hence web-based tool to administrate MySQL over the WWW"
+arch=('any')
+url="http://www.phpmyadmin.net"
+license=('GPL')
+depends=('mysql-clients' 'php')
+optdepends=('libmcrypt: to use phpMyAdmin internal authentication'
+ 'python2')
+backup=("etc/webapps/phpmyadmin/.htaccess"
+ "etc/webapps/phpmyadmin/config.inc.php")
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/phpMyAdmin-$pkgver-all-languages.tar.bz2)
+md5sums=('784b2534c443b1cb2328e3b97f0d2a36')
+
+build() {
+ _instdir=${startdir}/pkg/data/srv/httpd/htdocs/phpMyAdmin
+ mkdir -p ${_instdir} $pkgdir/etc/webapps/phpmyadmin
+ cd ${_instdir}
+
+ cp -ra $srcdir/phpMyAdmin-${pkgver}-all-languages/* .
+# echo "deny from all" >$pkgdir/etc/webapps/phpmyadmin/.htaccess
+
+ ln -s /etc/webapps/phpmyadmin/.htaccess ${_instdir}/.htaccess
+ ln -s /etc/webapps/phpmyadmin/config.inc.php ${_instdir}/config.inc.php
+ cp ${_instdir}/config.sample.inc.php $pkgdir/etc/webapps/phpmyadmin/config.inc.php
+ cp ${_instdir}/config.sample.inc.php $pkgdir/etc/webapps/phpmyadmin/
+
+ # apache
+# cat >$pkgdir/etc/webapps/phpmyadmin/apache.example.conf <<EOF
+# Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"
+# <Directory "/usr/share/webapps/phpMyAdmin">
+# AllowOverride All
+# Options FollowSymlinks
+# Order allow,deny
+# Allow from all
+# </Directory>
+#EOF
+
+}
+
+
diff --git a/abs/not_built/extra/phpmyadmin/__changelog b/abs/not_built/extra/phpmyadmin/__changelog
new file mode 100644
index 0000000..4ee3bf9
--- /dev/null
+++ b/abs/not_built/extra/phpmyadmin/__changelog
@@ -0,0 +1,2 @@
+Comment out all apache related stuff.
+optdepends: change 'python' to 'python2'