summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/sdl_perl/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/sdl_perl/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/sdl_perl/PKGBUILD')
-rw-r--r--abs/not_built/extra/sdl_perl/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/not_built/extra/sdl_perl/PKGBUILD b/abs/not_built/extra/sdl_perl/PKGBUILD
new file mode 100644
index 0000000..82552e8
--- /dev/null
+++ b/abs/not_built/extra/sdl_perl/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 85950 2010-07-22 19:09:33Z kevin $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+
+pkgname=sdl_perl
+_realname=SDL_Perl
+pkgver=2.2.6
+pkgrel=4
+pkgdesc="A Perl wrapper for SDL"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://sdl.perl.org"
+depends=('perl>=5.10.1' 'sdl_net' 'sdl_ttf' 'sdl_image>=1.2.8' 'sdl_mixer>=1.2.10'
+ 'mesa' 'sdl_gfx>=2.0.20' 'smpeg')
+makedepends=('perl-yaml')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/K/KT/KTHAKORE/${_realname}-v${pkgver}.tar.gz)
+md5sums=('445950ca7b9991f34ec792bbac8386b6')
+
+build() {
+ cd "${srcdir}/${_realname}-v${pkgver}"
+ # install module in vendor directories
+ perl Build.PL installdirs=vendor destdir="${pkgdir}" \
+ --config man1ext=1p --config man3ext=3pm || return 1
+ perl Build || return 1
+ perl Build install || return 1
+}