summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/wxpython/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/wxpython/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/wxpython/PKGBUILD')
-rw-r--r--abs/not_built/extra/wxpython/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/wxpython/PKGBUILD b/abs/not_built/extra/wxpython/PKGBUILD
new file mode 100644
index 0000000..b9375cc
--- /dev/null
+++ b/abs/not_built/extra/wxpython/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 88207 2010-08-21 05:14:19Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Andrew Wright <andreww@photism.org>
+
+pkgname=wxpython
+pkgver=2.8.11.0
+pkgrel=2
+pkgdesc="A wxWidgets GUI toolkit for Python"
+arch=('i686' 'x86_64')
+license=('custom:wxWindows')
+url="http://www.wxpython.org"
+depends=('wxgtk' 'python2')
+makedepends=('mesa')
+changelog=ChangeLog
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2 editra-aui.diff)
+md5sums=('63f73aae49e530852db56a31b57529fa' '06c637c34c1570d8c82b870ce19c0622')
+sha1sums=('18982edc236a1d87e4eef018928358c925aa5b17' '077fe341bf8822647934d6b1ea82ce9b0adbf93a')
+
+build() {
+ cd "${srcdir}/wxPython-src-${pkgver}"
+ patch -p1 < ../editra-aui.diff
+ ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
+ --enable-graphics_ctx --with-gnomeprint --disable-optimize --enable-mediactrl \
+ --with-libpng=sys --with-libxpm=sys --with-libjpeg=sys --with-libtiff=sys
+ cd "${srcdir}/wxPython-src-${pkgver}/wxPython"
+ python2 setup.py WXPORT=gtk2 UNICODE=1 build
+}
+
+package() {
+ cd "${srcdir}/wxPython-src-${pkgver}/wxPython"
+ python2 setup.py WXPORT=gtk2 UNICODE=1 install --root="${pkgdir}"
+ install -D -m644 ../docs/licence.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}