summaryrefslogtreecommitdiffstats
path: root/linhes/libfastjson/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-02-01 22:43:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-02-01 22:43:57 (GMT)
commitf60be96c26c0208a9df48f25c5f435292c0d6b6c (patch)
tree35165b3e7303e8d9746cd8500520aa181874fc1f /linhes/libfastjson/PKGBUILD
parent3182c24918895283783b5828937227046c8cbf13 (diff)
downloadlinhes_pkgbuild-f60be96c26c0208a9df48f25c5f435292c0d6b6c.zip
linhes_pkgbuild-f60be96c26c0208a9df48f25c5f435292c0d6b6c.tar.gz
linhes_pkgbuild-f60be96c26c0208a9df48f25c5f435292c0d6b6c.tar.bz2
move
Diffstat (limited to 'linhes/libfastjson/PKGBUILD')
-rw-r--r--linhes/libfastjson/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/linhes/libfastjson/PKGBUILD b/linhes/libfastjson/PKGBUILD
new file mode 100644
index 0000000..36e6a22
--- /dev/null
+++ b/linhes/libfastjson/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Luca P <meti at lplab.net>
+# Contributor: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Contributor: Bob Gregory <pathogenix@gmail.com>
+
+pkgname=libfastjson
+pkgver=0.99.9
+pkgrel=2
+pkgdesc="A performance-focused json library for C"
+arch=('x86_64' 'i686')
+url="https://github.com/rsyslog/libfastjson"
+license=('GPL')
+depends=()
+source=($pkgname-$pkgver.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('881f954633aa76931e4c756ece0bda6fd8a673c6e66955a3db3b2bb9d6bbff72')
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -fvi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}