summaryrefslogtreecommitdiffstats
path: root/linhes/linhes-system/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-01-13 20:28:21 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-01-13 20:28:21 (GMT)
commit4fb6cae217d09d74a912053f51d411bb38de4fa0 (patch)
tree1f5e6af0f68a491c5ed39380af979c6f5f144a6d /linhes/linhes-system/PKGBUILD
parent006fb5a9dd30bdbfcf47b599c489fa51da289b8d (diff)
downloadlinhes_pkgbuild-4fb6cae217d09d74a912053f51d411bb38de4fa0.zip
linhes_pkgbuild-4fb6cae217d09d74a912053f51d411bb38de4fa0.tar.gz
linhes_pkgbuild-4fb6cae217d09d74a912053f51d411bb38de4fa0.tar.bz2
linhes-system: add mce remote def
add misc scripts
Diffstat (limited to 'linhes/linhes-system/PKGBUILD')
-rwxr-xr-xlinhes/linhes-system/PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index c2d8499..636959a 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=linhes-system
pkgver=9.0.0
-pkgrel=23
+pkgrel=24
arch=('x86_64')
#install=$pkgname.install
pkgdesc="Everything that makes LinHES a system"
@@ -11,6 +11,8 @@ binfiles="add_storage.py balance_storage_groups.py empty_storage_groups.py remov
checkXFSfrag.sh enableIRWake.sh idle.py lh_system_start.sh lh_notify-send
lh_home_check.sh jobqueue_helper.py
diskspace.sh find_orphans.py optimize_mythdb.py
+ misc_recent_recordings.pl misc_status_config.py misc_status_info.sh
+ misc_upcoming_recordings.pl misc_which_recorder.pl
create_media_dirs.sh be_check.py
myth2mkv myth2mp3"
source=($binfiles
@@ -19,7 +21,7 @@ source=($binfiles
'79-cronie.hook' 'fstrim.hook' 'openssh.hook'
'10-monitor.conf' 'x11vnc.override.conf' 'lh_lighttpd.conf' 'lh_php.ini'
'system-sudo.rules' 'linhes-profile.sh' 'lh_sqlserver.cnf'
- 'lh_system_start.sh.desktop')
+ 'lh_system_start.sh.desktop' 'rc6_mce.toml')
sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
'b0e8fe4d04e1f779d52a28156489fb51efc13e173efccba2d6d458044bf35904'
'4ab36bbabf0964f666278c225f4c2d41f4277acb42e9023163fa3a9599282466'
@@ -34,6 +36,11 @@ sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
'ebdb3ee0212e0cc72526bb5e50a032573e1894acb7bf75617243b0b49aa1f8f2'
'4d006f0fe3b13e67de1b961d611e81911905a30d140849dfdb8e5c0dc4da2f7c'
'e371c6a289c68fe200d7da856c20a8c579efa23178f4d62235f7359d7f6e49a1'
+ 'd2d69b2bf6315bd37ff5f5b2f0cde8ab2fb89bae18f8796dc5208ffc1a9d743e'
+ 'a3f8ba840853e4a189dd52520a6958f4030e1cc3391200a6aeef055fb469f0b4'
+ '6a700f73241de796447bbaf9475b627ae5e662aec3f7fd42b7efa28333aa8801'
+ '62a5a195ddfaa13bbc7b5bc627cdd748f5d697d178a5238b71a703533bfdd587'
+ '1d12a128a01dbf6327a80daab9edfdc57d393d02074d19c6a5bd54560cc6b0c0'
'bffcc13e4b480f720feb2b3c781bc4247c63303250c3d885022c699573d45a33'
'51093acab5e5a4de51a55f4bdf7b935f4f69edf3d84f1c37db710853ec95eca8'
'9ea1b5583cd38f53bb79d9e4ccae91a028db0b6850162d7991b19122c564b9c9'
@@ -53,7 +60,8 @@ sha256sums=('7f91d2afcb76e8e9063c6bbe05f5c3d134a6f67541aead8894d342c32d34ad98'
'a9d0a94ff442453f0bec0b2e8afd591cf17b2845b6ae45ff300530114efd30af'
'47ace62d7e7e651f25dc7c0a2e96d0862f5efe1a583eeda2843b1fc1499141fe'
'3ed91fb5a7894f82fb4895e06d2e3f1df3ac4f82e46c970d4a85aaa4edc24cf1'
- '0b9868a563036c81f8fdb8ab8bbad51934aca2a07e9d7634e24214791afda8e2')
+ '0b9868a563036c81f8fdb8ab8bbad51934aca2a07e9d7634e24214791afda8e2'
+ '1b965b5e7eeafdf3815c8f2722587a560693dd780327cca9910dc47fba0f1aef')
package() {
cd $srcdir
@@ -84,6 +92,9 @@ package() {
#lighttpd files
install -Dm644 $srcdir/lh_lighttpd.conf $pkgdir/etc/lighttpd/conf.d/lh_lighttpd.conf
+ #remote files
+ install -Dm644 $srcdir/rc6_mce.toml $pkgdir/etc/rc_keymaps/rc6_mce.toml
+
#readme files
install -Dm644 $srcdir/readme_is_xml $pkgdir/etc/gen_is_xml.d/readme_is_xml
install -Dm644 $srcdir/readme_is_xml $pkgdir/etc/gen_lib_xml.d/readme_gen_xml