summaryrefslogtreecommitdiffstats
path: root/linhes/linhes-web/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-01-12 18:52:09 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-01-12 18:52:09 (GMT)
commit25b6fc226dd86c5a42d577a52b44ceb3d3926507 (patch)
tree0f0c6674826a97fda09a25cfafe82b200f1c1e51 /linhes/linhes-web/PKGBUILD
parent7e4d5c7659e2cc4b842f77eb27192883eb0062a8 (diff)
downloadlinhes_pkgbuild-25b6fc226dd86c5a42d577a52b44ceb3d3926507.zip
linhes_pkgbuild-25b6fc226dd86c5a42d577a52b44ceb3d3926507.tar.gz
linhes_pkgbuild-25b6fc226dd86c5a42d577a52b44ceb3d3926507.tar.bz2
linhes-web: add lighttpd conf file
Diffstat (limited to 'linhes/linhes-web/PKGBUILD')
-rw-r--r--linhes/linhes-web/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/linhes/linhes-web/PKGBUILD b/linhes/linhes-web/PKGBUILD
index 7f1d43f..0bb2824 100644
--- a/linhes/linhes-web/PKGBUILD
+++ b/linhes/linhes-web/PKGBUILD
@@ -1,17 +1,21 @@
pkgname=linhes-web
pkgver=9.0.0
-pkgrel=2
+pkgrel=3
conflicts=()
pkgdesc="LinHES local website"
depends=('lighttpd' 'php-cgi')
makedepends=()
arch=('x86_64')
license=('GPL')
-source=(website.tar.gz)
-sha256sums=('6ff99589d225826d86bd1911aa0223f3c9668c02ff15e7bc607e52d90cca20ae')
+source=('linhes-web.conf' 'website.tar.gz')
+sha256sums=('e39ce02bde5eb3d359f1286b41751aa715961cf2b2d9a1243c7f01d20ed9c993'
+ '6ff99589d225826d86bd1911aa0223f3c9668c02ff15e7bc607e52d90cca20ae')
package() {
mkdir -p $pkgdir/data/srv/httpd/htdocs/
cp -rp $srcdir/website/contents/* $pkgdir/data/srv/httpd/htdocs
chmod -R 755 $pkgdir/data/srv/httpd/htdocs
+
+ #lighttpd files
+ install -Dm644 $srcdir/linhes-web.conf $pkgdir/etc/lighttpd/conf.d/linhes-web.conf
}