summaryrefslogtreecommitdiffstats
path: root/linhes/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-02-18 01:49:19 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-02-18 01:49:19 (GMT)
commit406bd38a99f71eaf4c81e70c0728e1f9b2f78615 (patch)
tree5407c7b79f8ebddd7e5172843f7622c0a31a289c /linhes/mythtv/PKGBUILD
parentebc1cab4a2ecce3d444d0ba795833ccb1ec3defe (diff)
downloadlinhes_pkgbuild-406bd38a99f71eaf4c81e70c0728e1f9b2f78615.zip
linhes_pkgbuild-406bd38a99f71eaf4c81e70c0728e1f9b2f78615.tar.gz
linhes_pkgbuild-406bd38a99f71eaf4c81e70c0728e1f9b2f78615.tar.bz2
mythtv: add mythtv-setup.desktop and rename mythtv.desktop to mythfrontend.desktop
Diffstat (limited to 'linhes/mythtv/PKGBUILD')
-rw-r--r--linhes/mythtv/PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/linhes/mythtv/PKGBUILD b/linhes/mythtv/PKGBUILD
index e82becb..b204d52 100644
--- a/linhes/mythtv/PKGBUILD
+++ b/linhes/mythtv/PKGBUILD
@@ -83,18 +83,30 @@ replaces=('myththemes' 'mythplugins-mythvideo' 'mythtv-git')
source=(
"git+https://github.com/MythTV/mythtv#branch=fixes/32"
'mythbackend.service'
- 'mythtv.desktop'
+ 'mythfrontend.desktop'
+ 'mythtv-setup.desktop'
'mythtv.png'
'99-mythbackend.rules'
'sysusers.d'
)
sha256sums=('SKIP'
- '37c07fc6b1fac03f6c8ab394b3e2c8223ea7d8c6af0056d397f60f781916f2bb'
- '3fd2018d0d5aaa7d530835305dac80d4ca7d8fc991cdf9e1cebadebd86e25c03'
+ '6adb9d3370111c7d0000b215ae2d83a07a19c1bef5c22657f8caa9593c8efda5'
+ 'eb220f5c8995ced990678559456fc36fdde86c589770fcf390209a05980fc070'
+ 'e7965a0d232aefcf8e5e89a96f46b7582a9590d2ae9b4f5b8ee9ab2baa913527'
'12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
'470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
+prepare() {
+ msg2 "PKGBUILD pkgver: $pkgver"
+ cd "${srcdir}/mythtv/mythtv"
+ gitsrcver=`echo "32+fixes.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"`
+ msg2 "GIT SOURCE pkgver: $gitsrcver"
+ if [ $pkgver = $gitsrcver ]; then
+ warning "pkgver did NOT change. Consider increasing pkgrel ($pkgrel)."
+ fi
+}
+
pkgver() {
cd "${srcdir}/mythtv/mythtv"
echo -n "32+fixes.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"
@@ -103,6 +115,9 @@ pkgver() {
build() {
cd "${srcdir}/mythtv/mythtv"
+CFLAGS="-march=x86-64 -mtune=amdfam10 -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
+ -fstack-clash-protection -fcf-protection"
# CFLAGS="${CFLAGS/flto=auto/fPIC}"
# CXXFLAGS="${CXXFLAGS/flto=auto/fPIC}"
# LDFLAGS="${LDFLAGS/flto=auto/fPIC}"
@@ -143,5 +158,6 @@ package() {
# Install desktop file
install -Dm644 "$srcdir/mythtv.png" "$pkgdir/usr/share/pixmaps/mythtv.png"
- install -Dm644 "$srcdir/mythtv.desktop" "$pkgdir/usr/share/applications/mythtv.desktop"
+ install -Dm644 "$srcdir/mythfrontend.desktop" "$pkgdir/usr/share/applications/mythfrontend.desktop"
+ install -Dm644 "$srcdir/mythtv-setup.desktop" "$pkgdir/usr/share/applications/mythtv-setup.desktop"
}