summaryrefslogtreecommitdiffstats
path: root/linhes/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-03-04 18:55:31 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-03-04 18:55:31 (GMT)
commit67159108a4b90d6f70a3a765c8fe7f752fd75d53 (patch)
tree3da1e5c328c06b6678c0b9685aca415d80ea1d06 /linhes/mythtv/PKGBUILD
parent645f62d6848195221ebecc2e077fe36bba03bd17 (diff)
downloadlinhes_pkgbuild-67159108a4b90d6f70a3a765c8fe7f752fd75d53.zip
linhes_pkgbuild-67159108a4b90d6f70a3a765c8fe7f752fd75d53.tar.gz
linhes_pkgbuild-67159108a4b90d6f70a3a765c8fe7f752fd75d53.tar.bz2
mythtv: add patch for default theme and en_us title case
Diffstat (limited to 'linhes/mythtv/PKGBUILD')
-rw-r--r--linhes/mythtv/PKGBUILD25
1 files changed, 22 insertions, 3 deletions
diff --git a/linhes/mythtv/PKGBUILD b/linhes/mythtv/PKGBUILD
index b5fd959..a51a747 100644
--- a/linhes/mythtv/PKGBUILD
+++ b/linhes/mythtv/PKGBUILD
@@ -8,14 +8,13 @@
pkgname=mythtv
pkgver=33+fixes.20230219.c273ed0f
-pkgrel=2
+pkgrel=3
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
url="https://www.mythtv.org/"
license=('GPL')
depends=(
'exiv2'
-# 'fftw'
'lame'
'libass'
'libavc1394'
@@ -75,11 +74,16 @@ makedepends=(
'python-requests'
'python-setuptools'
'python-simplejson'
+ 'qt5-tools'
'yasm'
)
conflicts=('myththemes' 'mythplugins-mythvideo' 'mythtv-git')
replaces=('myththemes' 'mythplugins-mythvideo' 'mythtv-git')
+
+patches="defaultThemeLinHES.patch
+ mythfrontend_en_us.ts_Title_Case.patch"
+
source=(
"git+https://github.com/MythTV/mythtv#branch=fixes/33"
'mythbackend.service'
@@ -88,6 +92,7 @@ source=(
'mythtv.png'
'99-mythbackend.rules'
'sysusers.d'
+ $patches
)
sha256sums=('SKIP'
'6adb9d3370111c7d0000b215ae2d83a07a19c1bef5c22657f8caa9593c8efda5'
@@ -95,7 +100,9 @@ sha256sums=('SKIP'
'e7965a0d232aefcf8e5e89a96f46b7582a9590d2ae9b4f5b8ee9ab2baa913527'
'12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
- '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
+ 'ef1d0053d862a9c714093d375e20c96418d665fa504a5b8f30621a271d416dd8'
+ 'eb26e0cbf3ca3554479d19c383666721fbb5fe45c9dd24f2d36cbe29bcc0056f')
prepare() {
msg2 "PKGBUILD pkgver: $pkgver"
@@ -105,6 +112,18 @@ prepare() {
if [ $pkgver = $gitsrcver ]; then
warning "pkgver did NOT change. Consider increasing pkgrel ($pkgrel)."
fi
+
+ msg "--------------------------applying patches------------------------------"
+ for i in `echo ${patches[@]:0}`
+ do
+ echo applying $i
+ patch -Np2 -i ${srcdir}/$i || return 1
+ echo "-----------------------------"
+ done
+ msg "--------------------------done applying patches-------------------------"
+
+ msg "Updating en_us Translation"
+ lrelease -removeidentical i18n/mythfrontend_en_us.ts
}
pkgver() {