summaryrefslogtreecommitdiffstats
path: root/linhes/python-requests-cache/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2023-03-04 18:50:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2023-03-04 18:50:36 (GMT)
commit645f62d6848195221ebecc2e077fe36bba03bd17 (patch)
treea8e985609783b2e68d6dbd7aba62defe0cb41e3f /linhes/python-requests-cache/PKGBUILD
parent28cedd539f2204d968d7cdf9980c48570779a956 (diff)
downloadlinhes_pkgbuild-645f62d6848195221ebecc2e077fe36bba03bd17.zip
linhes_pkgbuild-645f62d6848195221ebecc2e077fe36bba03bd17.tar.gz
linhes_pkgbuild-645f62d6848195221ebecc2e077fe36bba03bd17.tar.bz2
python-requests-cache: update to 1.0.0
Diffstat (limited to 'linhes/python-requests-cache/PKGBUILD')
-rw-r--r--linhes/python-requests-cache/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/linhes/python-requests-cache/PKGBUILD b/linhes/python-requests-cache/PKGBUILD
index 3c2a826..3b12874 100644
--- a/linhes/python-requests-cache/PKGBUILD
+++ b/linhes/python-requests-cache/PKGBUILD
@@ -8,12 +8,12 @@
_base=requests-cache
pkgname=python-${_base}
pkgdesc="A transparent persistent cache for the requests library"
-pkgver=0.9.8
+pkgver=1.0.0
pkgrel=1
arch=(any)
-url="https://github.com/reclosedev/${_base}"
+url="https://github.com/${_base}/${_base}"
license=('custom:BSD-2-clause')
-depends=(python-requests python-appdirs python-cattrs python-url-normalize)
+depends=(python-requests python-platformdirs python-cattrs python-url-normalize)
makedepends=(python-poetry-core python-build python-installer python-wheel)
optdepends=(
'python-boto3: Cache backend for Amazon DynamoDB database'
@@ -25,9 +25,9 @@ optdepends=(
'python-yaml: for bindings yaml support'
'python-ujson: for JSON serializer for improved performance'
)
-checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator)
+checkdepends=(python-pytest python-requests-mock python-responses python-itsdangerous python-ujson python-timeout-decorator python-rich)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('f428a7b498d2ef2b6c23d3715bac2274c320b6f9d6f56017e69ab5fa6b8830242a2f335ed6c3758a741a51f108c6dacae1a447ff8f05ca5686303caf48a1dc59')
+sha512sums=('92d6e1b9afb158f824a4b20d83c7b30a5988476b741213b0663df6095df1753da2dcd6516372ba383864e19d346850a356e9370b2ae27554effcc3f0b6a078c8')
build() {
cd ${_base}-${pkgver}