summaryrefslogtreecommitdiffstats
path: root/linhes/python-timeout-decorator/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2022-11-30 23:13:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2022-11-30 23:13:47 (GMT)
commit7fe52fda6fdd65ddc683f860fee93488fea06a55 (patch)
tree8a8f55280ec695992d78a4951b56518466354629 /linhes/python-timeout-decorator/PKGBUILD
parent9bf49fdc29a0fa6872f39a6cfcf1b2034380888d (diff)
downloadlinhes_pkgbuild-7fe52fda6fdd65ddc683f860fee93488fea06a55.zip
linhes_pkgbuild-7fe52fda6fdd65ddc683f860fee93488fea06a55.tar.gz
linhes_pkgbuild-7fe52fda6fdd65ddc683f860fee93488fea06a55.tar.bz2
python-timeout-decorator: initial inclusion
Diffstat (limited to 'linhes/python-timeout-decorator/PKGBUILD')
-rw-r--r--linhes/python-timeout-decorator/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/linhes/python-timeout-decorator/PKGBUILD b/linhes/python-timeout-decorator/PKGBUILD
new file mode 100644
index 0000000..16d9f89
--- /dev/null
+++ b/linhes/python-timeout-decorator/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: robertfoster
+
+_name=timeout-decorator
+pkgname=python-${_name}
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Timeout decorator for Python"
+arch=('i686' 'x86_64' 'armv6')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://github.com/pnpnpn/timeout-decorator"
+license=('MIT')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/t/${_name}/${_name}-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py install \
+ --root="$pkgdir" \
+ --optimize=1
+}
+
+md5sums=('8545649e70b3ca43bcff11f08a996c3e')