summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.sh29
2 files changed, 7 insertions, 24 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 40914cf..b8fbb9a 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=237
+pkgrel=240
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index 9f4df7a..06402a6 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -371,32 +371,15 @@ function setupnciddaemon {
}
function setupntp () {
-cat > ${BASE}/etc/ntp.conf << EOF
-# default restrictions
-restrict default noquery notrust nomodify
-# NTP drift file - used to keep track of your system clocks
-# time deviation
-driftfile /etc/ntp.drift
-
-# NTP log file
-logfile /var/log/ntp.log
-# override the default restrictions here, servers that can query
-restrict 192.168.0.0 mask 255.255.0.0 nomodify
-restrict 10.0.0.0 mask 255.0.00 nomodify
-
-#servers to sync with
-EOF
#this is used for backend or standlone types
- if [ $1 = "1" ]
+ if [ $1 = "1" ]
then
- echo "server pool.ntp.org" >> ${BASE}/etc/ntp.conf
- #echo "server ntp3.sf-bay.org" >> ${BASE}/etc/ntp.conf
- echo "restrict pool.ntp.org" >> ${BASE}/etc/ntp.conf
- #echo "restrict ntp3.sf-bay.org noquery nomodify" >> ${BASE}/etc/ntp.conf
-
+ #MBE/STD use deafult
+ echo "Not changing ntp config"
else
- echo "server $dbhost" >> ${BASE}/etc/ntp.conf
- echo "restrict $dbhost noquery nomodify" >> ${BASE}/etc/ntp.conf
+ #echo "server $dbhost" >> ${BASE}/etc/ntp.conf
+ echo "setting ntp to $dbhost"
+ sed -i "s/pool.ntp.org/$dbhost/g" ${BASE}/etc/ntp.conf
fi