summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/dbus-core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/dbus-core')
-rw-r--r--abs/core-testing/dbus-core/PKGBUILD53
-rw-r--r--abs/core-testing/dbus-core/dbus57
-rw-r--r--abs/core-testing/dbus-core/dbus.install24
3 files changed, 0 insertions, 134 deletions
diff --git a/abs/core-testing/dbus-core/PKGBUILD b/abs/core-testing/dbus-core/PKGBUILD
deleted file mode 100644
index b57829f..0000000
--- a/abs/core-testing/dbus-core/PKGBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# $Id: PKGBUILD 73272 2010-03-24 11:36:47Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: Link Dupont <link@subpop.net>
-#
-pkgname=dbus-core
-pkgver=1.2.24
-pkgrel=1
-pkgdesc="Freedesktop.org message bus system"
-url="http://www.freedesktop.org/Software/dbus"
-arch=(i686 x86_64)
-license=('GPL' 'custom')
-depends=('expat>=2.0.1' 'coreutils' 'filesystem')
-conflicts=('dbus<1.2.3-2')
-options=(!libtool)
-install=dbus.install
-source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
- dbus)
-md5sums=('565346cecd9cfecf1463540c6086cc2c'
- '08f93dd19cffd1b45ab05c1fd4efb560')
-
-build() {
- cd "${srcdir}/dbus-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
- --with-system-pid-file=/var/run/dbus.pid \
- --enable-inotify --disable-dnotify \
- --disable-verbose-mode --disable-static \
- --disable-tests --disable-asserts --without-x || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
-
- rm -f "${pkgdir}/usr/bin/dbus-launch"
- rm -f "${pkgdir}/usr/share/man/man1/dbus-launch.1"
-
- chown 81:81 "${pkgdir}/var/run/dbus" || return 1
-
- install -m755 -d "${pkgdir}/etc/rc.d" || return 1
- install -m755 "${srcdir}/dbus" "${pkgdir}/etc/rc.d/" || return 1
-
- #Fix configuration file
- sed -i -e 's|<user>81</user>|<user>dbus</user>|' "${pkgdir}/etc/dbus-1/system.conf" || return 1
-
- #install .keep files so pacman doesn't delete empty dirs
- touch "${pkgdir}/usr/share/dbus-1/services/.keep" || return 1
- touch "${pkgdir}/usr/share/dbus-1/system-services/.keep" || return 1
- touch "${pkgdir}/etc/dbus-1/session.d/.keep" || return 1
- touch "${pkgdir}/etc/dbus-1/system.d/.keep" || return 1
-
- rmdir "${pkgdir}/usr/lib/dbus-1.0/dbus-1" || return 1
-
- install -d -m755 "${pkgdir}/usr/share/licenses/dbus-core"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/dbus-core/" || return 1
-}
diff --git a/abs/core-testing/dbus-core/dbus b/abs/core-testing/dbus-core/dbus
deleted file mode 100644
index 66b84ca..0000000
--- a/abs/core-testing/dbus-core/dbus
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/bash
-
-# general config
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-case "$1" in
- start)
- stat_busy "Starting D-BUS system messagebus"
- if [ ! -x /var/run/dbus ] ; then
- install -m755 -g 81 -o 81 -d /var/run/dbus
- fi
- if [ -x /usr/bin/dbus-uuidgen ] ; then
- /usr/bin/dbus-uuidgen --ensure
- fi
-
- /usr/bin/dbus-daemon --system
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon dbus
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping D-BUS system messagebus"
- [ -f /var/run/dbus.pid ] && kill `cat /var/run/dbus.pid` >/dev/null 2>&1
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm -f /var/run/dbus.pid
- rm_daemon dbus
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- reload)
- stat_busy "Reloading D-BUS configuration"
- [ -f /var/run/dbus.pid ] && /usr/bin/dbus-send \
- --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig
- if [ $? -gt 0 ]; then
- stat_fail
- else
- stat_done
- fi
- ;;
- *)
- echo "usage: $0 {start|stop|restart|reload}"
- ;;
-esac
-exit 0
diff --git a/abs/core-testing/dbus-core/dbus.install b/abs/core-testing/dbus-core/dbus.install
deleted file mode 100644
index 44f4475..0000000
--- a/abs/core-testing/dbus-core/dbus.install
+++ /dev/null
@@ -1,24 +0,0 @@
-post_install() {
- getent group dbus >/dev/null || usr/sbin/groupadd -g 81 dbus
- getent passwd dbus >/dev/null || usr/sbin/useradd -c 'System message bus' -u 81 -g dbus -d '/' -s /bin/false dbus
- usr/bin/passwd -l dbus &>/dev/null
- dbus-uuidgen --ensure
-}
-
-post_upgrade() {
- post_install
-
- #Make sure new rc script can shutdown running dbus
- if [ -f var/run/dbus/pid ]; then
- mv var/run/dbus/pid var/run/dbus.pid
- fi
-}
-
-post_remove() {
- if getent passwd dbus >/dev/null; then
- usr/sbin/userdel dbus
- fi
- if getent group dbus >/dev/null; then
- usr/sbin/groupdel dbus
- fi
-}