summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/iproute/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/iproute/PKGBUILD')
-rw-r--r--abs/core-testing/iproute/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/iproute/PKGBUILD b/abs/core-testing/iproute/PKGBUILD
new file mode 100644
index 0000000..ae0f9f0
--- /dev/null
+++ b/abs/core-testing/iproute/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 3746 2008-06-30 20:09:01Z andyrtr $
+# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=iproute
+#_dlver=2.6.24-rc7
+#pkgver=$(echo ${_dlver} | sed 's|-|_|g')
+pkgver=2.6.25
+pkgrel=1
+pkgdesc="IP Routing Utilities"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.linux-foundation.org/en/Net:Iproute2"
+depends=('db>=4.7')
+source=(#http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${_dlver}.tar.bz2
+ http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${pkgver}.tar.bz2)
+options=('force')
+md5sums=('5737bade2f5e03fad0e2c81da91e551e')
+
+build() {
+ #cd $srcdir/iproute2-${_dlver}
+ cd $srcdir/iproute2-${pkgver}
+ sed -i 's|/usr/local/lib/iptables|/usr/lib/iptables|' include/iptables.h || return 1
+ ./configure
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ chmod 755 $pkgdir/usr/sbin/ifcfg
+}