summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/kernel26/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/kernel26/PKGBUILD')
-rw-r--r--abs/core-testing/kernel26/PKGBUILD265
1 files changed, 0 insertions, 265 deletions
diff --git a/abs/core-testing/kernel26/PKGBUILD b/abs/core-testing/kernel26/PKGBUILD
deleted file mode 100644
index 01f2398..0000000
--- a/abs/core-testing/kernel26/PKGBUILD
+++ /dev/null
@@ -1,265 +0,0 @@
-# $Id: PKGBUILD 86792 2010-08-04 14:39:45Z thomas $
-# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
-# Maintainer: Heiko Baums <heiko@baums-on-web.de>
-# pkgbase="kernel26"
-pkgname=('kernel26' 'kernel26-headers' 'kernel26-manpages' 'kernel26-docs') # Build stock -ARCH kernel
-#pkgname=kernel26-fbcondecor # Build kernel with a different name
-_kernelname=${pkgname#kernel26}
-_basekernel=2.6.34
-pkgver=${_basekernel}.2
-pkgrel=2
-_patchname="patch-${pkgver}-${pkgrel}-ARCH"
-_fbpatchname="fbcondecor-0.9.6-2.6.33-rc7.patch"
-pkgdesc="The Linux Kernel and modules"
-arch=(i686 x86_64)
-license=('GPL2')
-url="http://www.kernel.org"
-backup=(etc/mkinitcpio.d/${pkgname}.preset)
-depends=('coreutils' 'linux-firmware' 'module-init-tools' 'mkinitcpio>=0.5.20')
-# pwc, ieee80211 and hostap-driver26 modules are included in kernel26 now
-# nforce package support was abandoned by nvidia, kernel modules should cover everything now.
-# kernel24 support is dropped since glibc24
-replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
- 'alsa-driver' 'ieee80211' 'hostap-driver26'
- 'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
- 'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
- 'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm')
-install=kernel26.install
-optdepends=('crda: to set the correct wireless channels of your country')
-source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
- ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
- http://dev.gentoo.org/~spock/projects/fbcondecor/archive/${_fbpatchname}
- fbcondecor-2.6.34-fix.patch
- # the main kernel config files
- config config.x86_64
- # standard config files for mkinitcpio ramdisk
- kernel26.preset)
-
-build() {
- KARCH=x86
-
- cd ${srcdir}
- patch -Np0 -i fbcondecor-2.6.34-fix.patch || return 1
-
- cd ${srcdir}/linux-$_basekernel
- # Add -ARCH patches
- # See http://projects.archlinux.org/linux-2.6-ARCH.git/
- patch -Np1 -i ${srcdir}/${_patchname} || return 1
- patch -Np1 -i ${srcdir}/${_fbpatchname} || return 1
-
- if [ "$CARCH" = "x86_64" ]; then
- cat ../config.x86_64 >./.config
- else
- cat ../config >./.config
- fi
- if [ "${_kernelname}" != "" ]; then
- sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
- fi
-## A hack to prevent output kernel from being marked as dirty or git
- sed 's/head=$(git rev-parse --verify --short HEAD 2>\/dev\/null)/0/' \
- ${srcdir}/linux-$_basekernel/scripts/setlocalversion \
- > ${srcdir}/linux-$_basekernel/scripts/setlocalversion
-##
- # get kernel version
- make prepare
- # load configuration
- # Configure the kernel. Replace the line below with one of your choice.
- #make menuconfig # CLI menu for configuration
- #make xconfig # X-based configuration
- #make oldconfig # using old config from previous kernel version
- # ... or manually edit .config
- ####################
- # stop here
- # this is useful to configure the kernel
- #msg "Stopping build"
- #return 1
- ####################
- yes "" | make config
- # build!
- make bzImage modules || return 1
- }
-
-package_kernel26() {
- pkgdesc="The Linux Kernel and modules"
- groups=('base')
- backup=(etc/mkinitcpio.d/${pkgname}.preset)
- depends=('coreutils' 'linux-firmware' 'module-init-tools' 'mkinitcpio>=0.5.20')
- # pwc, ieee80211 and hostap-driver26 modules are included in kernel26 now
- # nforce package support was abandoned by nvidia, kernel modules should cover everything now.
- # kernel24 support is dropped since glibc24
- replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
- 'alsa-driver' 'ieee80211' 'hostap-driver26'
- 'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
- 'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
- 'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm')
- install=kernel26.install
- optdepends=('crda: to set the correct wireless channels of your country')
-
- KARCH=x86
- cd ${srcdir}/linux-$_basekernel
- # get kernel version
- _kernver="$(make kernelrelease)"
- mkdir -p ${pkgdir}/{lib/modules,boot}
- make INSTALL_MOD_PATH=${pkgdir} modules_install || return 1
- cp System.map ${pkgdir}/boot/System.map26${_kernelname}
- cp arch/$KARCH/boot/bzImage ${pkgdir}/boot/vmlinuz26${_kernelname}
- # # add vmlinux
- install -m644 -D vmlinux ${pkgdir}/usr/src/linux-${_kernver}/vmlinux
-
- # install fallback mkinitcpio.conf file and preset file for kernel
- install -m644 -D ${srcdir}/kernel26.preset ${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset || return 1
- # set correct depmod command for install
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
- -i $startdir/kernel26.install
- sed \
- -e "s|source .*|source /etc/mkinitcpio.d/kernel26${_kernelname}.kver|g" \
- -e "s|default_image=.*|default_image=\"/boot/${pkgname}.img\"|g" \
- -e "s|fallback_image=.*|fallback_image=\"/boot/${pkgname}-fallback.img\"|g" \
- -i ${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset
-
- echo -e "# DO NOT EDIT THIS FILE\nALL_kver='${_kernver}'" > ${pkgdir}/etc/mkinitcpio.d/${pkgname}.kver
- # remove build and source links
- rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
- # remove the firmware
- rm -rf ${pkgdir}/lib/firmware
-}
-
-package_kernel26-headers() {
- pkgdesc="Header files and scripts for building modules for kernel26"
- mkdir -p ${pkgdir}/lib/modules/${_kernver}
- cd ${pkgdir}/lib/modules/${_kernver}
- ln -sf ../../../usr/src/linux-${_kernver} build
- cd ${srcdir}/linux-$_basekernel
- install -D -m644 Makefile \
- ${pkgdir}/usr/src/linux-${_kernver}/Makefile
- install -D -m644 kernel/Makefile \
- ${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile
- install -D -m644 .config \
- ${pkgdir}/usr/src/linux-${_kernver}/.config
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include
-
- for i in acpi asm-generic config generated linux math-emu media net pcmcia scsi sound trace video; do
- cp -a include/$i ${pkgdir}/usr/src/linux-${_kernver}/include/
- done
-
- # copy arch includes for external modules
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/x86
- cp -a arch/x86/include ${pkgdir}/usr/src/linux-${_kernver}/arch/x86/
-
- # copy files necessary for later builds, like nvidia and vmware
- cp Module.symvers ${pkgdir}/usr/src/linux-${_kernver}
- cp -a scripts ${pkgdir}/usr/src/linux-${_kernver}
- # fix permissions on scripts dir
- chmod og-w -R ${pkgdir}/usr/src/linux-${_kernver}/scripts
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions
-
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel
-
- cp arch/$KARCH/Makefile ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
- if [ "$CARCH" = "i686" ]; then
- cp arch/$KARCH/Makefile_32.cpu ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
- fi
- cp arch/$KARCH/kernel/asm-offsets.s ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel/
-
- # add headers for lirc package
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video
- cp drivers/media/video/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/
- for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102 usbvideo zc0301; do
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
- cp -a drivers/media/video/$i/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
- done
- # add docbook makefile
- install -D -m644 Documentation/DocBook/Makefile \
- ${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile
- # add dm headers
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
- cp drivers/md/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
- # add inotify.h
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/linux
- cp include/linux/inotify.h ${pkgdir}/usr/src/linux-${_kernver}/include/linux/
- # add wireless headers
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
- cp net/mac80211/*.h ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
- # add dvb headers for external modules
- # in reference to:
- # http://bugs.archlinux.org/task/9912
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core
- cp drivers/media/dvb/dvb-core/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core/
- # add dvb headers for external modules
- # in reference to:
- # http://bugs.archlinux.org/task/11194
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
- cp include/config/dvb/*.h ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
- # add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
- # in reference to:
- # http://bugs.archlinux.org/task/13146
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
- cp drivers/media/dvb/frontends/lgdt330x.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
- cp drivers/media/video/msp3400-driver.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
- # add xfs and shmem for aufs building
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/mm
- cp fs/xfs/xfs_sb.h ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h
- # add headers vor virtualbox
- # in reference to:
- # http://bugs.archlinux.org/task/14568
- cp -a include/drm $pkgdir/usr/src/linux-${_kernver}/include/
- # add headers for broadcom wl
- # in reference to:
- # http://bugs.archlinux.org/task/14568
- cp -a include/trace $pkgdir/usr/src/linux-${_kernver}/include/
- # copy in Kconfig files
- for i in `find . -name "Kconfig*"`; do
- mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
- cp $i ${pkgdir}/usr/src/linux-${_kernver}/$i
- done
-
- chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
- find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
- # remove unneeded architectures
- rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,arm,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,xtensa}
-}
-
-#package_kernel26-firmware() {
-# pkgdesc="The included firmware files of the Linux Kernel"
-# groups=('base')
-#
-# cd ${srcdir}/linux-$_basekernel
-# make firmware || return 1
-# make INSTALL_MOD_PATH=${pkgdir} firmware_install || return 1
-#}
-
-package_kernel26-manpages() {
-pkgdesc="Kernel hackers manual - Section 9 manpages that comes with the Linux kernel."
-
-cd ${srcdir}/linux-$_basekernel
-make mandocs || return 1
-
-install -d ${pkgdir}/usr/share/man/man9/
-install ${srcdir}/linux-${_basekernel}/Documentation/DocBook/man/*.9.gz \
-${pkgdir}/usr/share/man/man9/
-
-find ${pkgdir} -type f -exec chmod 644 {} \;
-}
-
-package_kernel26-docs() {
-pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel."
-
-cd ${srcdir}/linux-$_basekernel
-mkdir -p $pkgdir/usr/src/linux-$_kernver
-mv Documentation $pkgdir/usr/src/linux-$_kernver
-find $pkgdir -type f -exec chmod 444 {} \;
-find $pkgdir -type d -exec chmod 755 {} \;
-# remove a file already in kernel26 package
-rm -f $pkgdir/usr/src/linux-$_kernver/Documentation/DocBook/Makefile
-}
-md5sums=('10eebcb0178fb4540e2165bfd7efc7ad'
- '2a8f0f455395296a1678b226ae63c5a7'
- 'c72c30fc2787e6d5d72ffae3cfb5341b'
- 'ed65c8f0da0d8159ce4bfc198657ea83'
- '6f37aeab713a3d59185a53066c923092'
- 'c81068add4917fca813417e8aa6c4f22'
- '25584700a0a679542929c4bed31433b6')