summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libcups/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libcups/PKGBUILD')
-rw-r--r--abs/core-testing/libcups/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core-testing/libcups/PKGBUILD b/abs/core-testing/libcups/PKGBUILD
new file mode 100644
index 0000000..363a46a
--- /dev/null
+++ b/abs/core-testing/libcups/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 7638 2008-08-03 15:54:53Z jgc $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+pkgname=libcups
+pkgver=1.3.8
+pkgrel=2
+pkgdesc="The CUPS Printing System"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.cups.org/"
+depends=('gnutls>=2.4.1' 'libtiff' 'libpng' 'heimdal>=1.2')
+source=(http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2)
+md5sums=('84e09577d673b212f605dd09caee456c')
+
+build() {
+ cd ${srcdir}/cups-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
+ --with-cups-user=daemon --with-cups-group=lp --enable-ssl=yes \
+ --disable-ldap --disable-dbus --libdir=/usr/lib
+
+ for dir in cups filter; do
+ pushd ${dir}
+ make
+ make BUILDROOT=${pkgdir} install
+ popd
+ done
+
+ mkdir -p ${startdir}/pkg/usr/bin
+ install -m755 cups-config ${startdir}/pkg/usr/bin/cups-config
+ #Remove filters
+ rm -rf ${startdir}/pkg/usr/lib/cups
+}