summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libdownload/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libdownload/PKGBUILD')
-rw-r--r--abs/core-testing/libdownload/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core-testing/libdownload/PKGBUILD b/abs/core-testing/libdownload/PKGBUILD
new file mode 100644
index 0000000..7685097
--- /dev/null
+++ b/abs/core-testing/libdownload/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 2480 2008-06-03 15:53:46Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=libdownload
+pkgver=1.3
+pkgrel=10
+pkgdesc="URL based download library, forked from libfetch"
+arch=('i686' 'x86_64')
+license=('BSD')
+groups=('base')
+depends=('glibc')
+url="http://code.phraktured.net/?p=libdownload.git"
+source=(http://code.phraktured.net/source/$pkgname-$pkgver.tar.gz)
+md5sums=('77e10293fd4262745110eb423a10490c')
+
+build() {
+ cd $startdir/src/${pkgname}-${pkgver}
+ [ "$CARCH" = "x86_64" ] && sed -i -e "s/-O2\ -pipe/-O2\ -pipe\ \-fPIC/g" Makefile
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}