summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libx86/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libx86/PKGBUILD')
-rw-r--r--abs/core-testing/libx86/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core-testing/libx86/PKGBUILD b/abs/core-testing/libx86/PKGBUILD
new file mode 100644
index 0000000..5cf3488
--- /dev/null
+++ b/abs/core-testing/libx86/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: tardo <tardo@nagi-fanboi.net>
+
+pkgname=libx86
+pkgver=0.99
+pkgrel=1
+pkgdesc="Provides an lrmi interface that works on x86, am64 and alpha"
+arch=('i686' 'x86_64')
+url="http://www.codon.org.uk/~mjg59/libx86/"
+license=('custom')
+depends=('glibc')
+source=(http://www.codon.org.uk/~mjg59/libx86/downloads/libx86-$pkgver.tar.gz lrmi.patch)
+md5sums=('c426d4f29fdf3499158cf49d4f374315')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p1 < ../lrmi.patch
+ if [ "$CARCH" = "x86_64" ]; then
+ make BACKEND=x86emu || return 1
+ else
+ make || return 1
+ fi
+
+ make DESTDIR=$startdir/pkg install
+ install -D -m 644 COPYRIGHT $startdir/pkg/usr/share/licenses/$pkgname/COPYRIGHT
+}