summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libxcb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libxcb/PKGBUILD')
-rw-r--r--abs/core-testing/libxcb/PKGBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/abs/core-testing/libxcb/PKGBUILD b/abs/core-testing/libxcb/PKGBUILD
deleted file mode 100644
index cbe31bd..0000000
--- a/abs/core-testing/libxcb/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# $Id: PKGBUILD 79958 2010-05-09 18:41:21Z jgc $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=libxcb
-pkgver=1.6
-pkgrel=1
-pkgdesc="X11 client-side library"
-arch=(i686 x86_64)
-url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.6' 'libxdmcp' 'libxau')
-makedepends=('pkgconfig' 'libxslt' 'python')
-conflicts=('libx11<1.1.99.2')
-options=('!libtool')
-license=('custom')
-source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
- libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('b0a6fec4c02ec876f32bbd4b64ffe8a25f0da518'
- '3455e84642283bc91c8313af319002a20bbcbdf4')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch" || return 1
- libtoolize --force --copy || return 1
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
- ./configure --prefix=/usr --enable-xinput || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
-}