summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/lighttpd/PKGBUILD')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index 2c0132b..65de89d 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 13948 2008-09-30 12:03:07Z douglas $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
pkgname=lighttpd
pkgver=1.4.20
-pkgrel=1
+pkgrel=3
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -22,7 +19,7 @@ backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
options=('!libtool' 'emptydirs')
install='lighttpd.install'
source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d')
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d' lighttpd.conf)
md5sums=('ed6ee0bb714f393219a32768d86984d8'
'bd690eee0d9e51857448770a151023b0'
@@ -54,18 +51,23 @@ build() {
install -D -m755 ../lighttpd.rc.d $pkgdir/etc/rc.d/lighttpd
install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
install -d -m755 $pkgdir/var/run/lighttpd/
+ install -d -m755 $pkgdir/var/run/lighttpd/
install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
- install -D -m644 doc/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
- # set sane defaults
- sed -e 's|/srv/www/htdocs/|/srv/http/|' \
- -e 's|/srv/www/|/srv/http/|' \
- -e 's|#server.username = "wwwrun"|server.username = "http"|' \
- -e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
- -e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
- -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
- -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ # set sane defaults
+ #sed -e 's|/srv/www/htdocs/|/srv/http/|' \
+ # -e 's|/srv/www/|/srv/http/|' \
+ # -e 's|#server.username = "wwwrun"|server.username = "http"|' \
+ # -e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
+ # -e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
+ # -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+ # -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ install -D -m644 $startdir/src/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
+
+#changelog
+#remove ldap
+#add custom lighttpd.conf