summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/lighttpd')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD11
-rw-r--r--abs/core-testing/lighttpd/__changelog2
-rw-r--r--abs/core-testing/lighttpd/lighttpd.conf2
3 files changed, 11 insertions, 4 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index bbb0a39..0e43272 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.26
-pkgrel=9
+pkgrel=12
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -65,13 +65,20 @@ build() {
-e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
-e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
-e 's|"^/mythweb|"^/{1,2}mythweb|' \
+ -e 's|# "mod_proxy",| "mod_proxy",|' \
+ -e 's|# "mod_ssi",| "mod_ssi",|' \
+ -e 's|#ssi.extension = ( ".shtml" )|ssi.extension = ( ".shtml" )|' \
-i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ /bin/touch $pkgdir/etc/lighttpd/{conf,html}.include || return 1
+ /bin/echo 'include "/etc/lighttpd/conf.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+ /bin/echo 'include "/etc/lighttpd/html.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
md5sums=('a682c8efce47a2f4263a247ba0813c9b'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- '07b8459b54fb2e70280064c2a275b176'
+ '11fbec7ff7ca1b0d5575445681e8f60e'
'c6e361131000ceec085f40b310ef4a2c'
'84c884b8dadd724afe2bc6529e9d4485')
diff --git a/abs/core-testing/lighttpd/__changelog b/abs/core-testing/lighttpd/__changelog
index 63bc373..5c0a14f 100644
--- a/abs/core-testing/lighttpd/__changelog
+++ b/abs/core-testing/lighttpd/__changelog
@@ -6,4 +6,4 @@ upgraded to 1.4.26 to address http://linhes.org/flyspray/index.php?do=details&ta
Added -e 's|"^/mythweb|"^/{1,2}mythweb|' \ to the sed command to work around lighttpd no longer honoring // in a url and/or to work around mythweb producing url's with a // for streaming and downloading.
changed lightttpd.conf to user perl for .cgi (needed for monx)_
-
+added 404 page
diff --git a/abs/core-testing/lighttpd/lighttpd.conf b/abs/core-testing/lighttpd/lighttpd.conf
index af7d134..f437484 100644
--- a/abs/core-testing/lighttpd/lighttpd.conf
+++ b/abs/core-testing/lighttpd/lighttpd.conf
@@ -145,7 +145,7 @@ static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
#server.bind = "127.0.0.1"
## error-handler for status 404
-#server.error-handler-404 = "/error-handler.html"
+server.error-handler-404 = "/404.html"
#server.error-handler-404 = "/error-handler.php"
## to help the rc.scripts